Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

[resolved] osTicket send an email to support only after login to the portal

Osticket send mails only after login to the webinterface!

I setup the crontab:
1. crontab -e
2. */5 * * * * root /usr/bin/php /var/www/html/osticket/api/cron.php

But it didn't work. Please help!))

osTicket: v 1.9.12
Tagged:

Comments

  • You have not provided us with enough information to assist you.  Please help us to help you by reading and following the posting guidelines located in this thread: Please read before requesting assistance.  The more information you give us the better we will be able to assist you. Thank you.

    Email settings?
    Your webserver runs as root?
    /usr/bin/php is your actual path to PHP?
    /var/www/html/osticket/api/cron.php is your actual path to cron.php?

  • PHP version 5.6.20  which php = /usr/bin/php is actual path

    /var/www/html/osticket/api/cron.php is the dirct phat to cron.php

    crontab */5 * * * * root /usr/bin/php /var/www/html/osticket/api/cron.php

    Operating System: MAC

    The cronjob doesn't wokt((( 


    Bildschirmfoto 2016-07-25 um 11.24.13.png
    875 x 624 - 144K
  • You should disable Fetch on Auto-cron if you are running cron.

    Your webserver runs as user root?
    Do you only have one version of PHP installed?
    I've never run a webserver or cron on a Mac before so you are likely going to have to play with the settings for your cron to get it to actually run.  You can also consult your PHP error log and see if there are any errors.
  • Ohu Sorry it's not Mac, it's Debian :(|) sry

    How can I find out, if the webserver runs with root?

    I disable Fetch on Auto-cron.
  • webserver is running as www-data user.
  • Then your cron job should also run as www-data.

    You didn't answer: Do you only have one version of PHP installed?

    Have you consulted your PHP error log to see if there are any errors?
  • edited July 2016
    Yes, I have only one version of PHP "5.6.20"

    In syslog cames every 5 min this line:

    Jul 28 11:25:01 ******* CRON[1535]: (root) CMD (www-data /usr/bin/php /var/www/html/osticket/api/cron.php)
    Jul 28 11:30:01 ******* CRON[1543]: (root) CMD (www-data /usr/bin/php /var/www/html/osticket/api/cron.php)

    But the mails will not be sent//
  • And once again... PHP error log?

  • /var/log/apache2/error.log

    [Thu Jul 28 09:40:37.436032 2016] [mpm_prefork:notice] [pid 830] AH00169: caught SIGTERM, shutting down
    [Thu Jul 28 09:40:53.263409 2016] [ssl:warn] [pid 503] AH01906: ***::443:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Thu Jul 28 09:40:53.264246 2016] [ssl:warn] [pid 503] AH01909: ***:443:0 server certificate does NOT include an ID which matches the server name
    [Thu Jul 28 09:40:54.042600 2016] [ssl:warn] [pid 512] AH01906: ***::443:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Thu Jul 28 09:40:54.042646 2016] [ssl:warn] [pid 512] AH01909: ***::443:0 server certificate does NOT include an ID which matches the server name
    [Thu Jul 28 09:40:54.045624 2016] [mpm_prefork:notice] [pid 512] AH00163: Apache/2.4.10 (Debian) OpenSSL/1.0.1k configured -- resuming normal operations
    [Thu Jul 28 09:40:54.045667 2016] [core:notice] [pid 512] AH00094: Command line: '/usr/sbin/apache2'
  • That is your Apache error log.  Not your PHP error log.
  • Sorry, i can't find it. hepl me pls!
  • Consult your php.ini it is specified in your config file.
  • I solved the problem. I configured the cron job in cron.d and not in crontab. Thx for your help.
  • [resolved]

This discussion has been closed.