Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

osTicket (v1.9.8.1) - LDAP Lookup Problem

Hello all --

I've spent about 3 days now trying to resolve this issue on a secondary deployment of OSTicket, but I've hit a wall.

OsTicket: 1.9.8.1
Linux/CentOS
PHP Version: 5.3.29
Apache/2.2.29 (Unix)

I've installed the LDAP Authentication and Lookup plugin. It installs fine, and I get no errors.


I am able to authenticate against Active Directory for Agents/Staff - but I cannot get the "Lookup" functionality to work for clients.

In our primary deployment of OSTicket  (v1.9.8) - when we go to the user registration we can start typing the user's login (jdoe for example) and it will pop up and let us pick that user from LDAP and prepopulates the registration form.

On this secondary deployment, it does not behave the same way. Nothing appears when we try the lookup.

I've tried everything I could find out there and I've checked the configuration multiple times and tried multiple different ways.

Does anyone have any recommendations on what I could be missing?
Tagged:

Comments

  • Have you imported your users into osTicket?
  • Hi ntozier --

    I'm not sure what you mean? I expected the lookup function of the plugin to allow me to do this when I go to add a new user?

    Thanks!
  • edited August 2016
    Hi Ntozier --

    The way it works in our (v1.9.8) deployment - configured the exact same way is when you go to add a user you start typing their Active Directory username, and it pops up with the user it found which you can click on to fill in the registration form. We're not getting the same results in the 1.9.8.1 deployment configured exactly the same.

    See pic below of how I'm expecting it to work:
    image
  • Thats not how it has ever worked on my installation.
  • I wasn't involved in the original deployment of v1.9.8 - but the install notes say they got it working by using this plugin. How does yours work?
  • users had to be imported or register for an account prior to being able to authenticate with LDAP/AD.
  • In our v1.9.8 environment, when I go to "Users" and click "Add User". The account registration pops up, and I can start typing in the person's AD account name. It pops up the user with "Remote" and I can click it to autofill the registration form and register the person.

    That is the behavior I am expecting from my 2nd deployment on v1.9.8.1 that is not working - and the configuration is exactly the same for the plugin on both.

    Is there something else that someone could have done to the original deployment to achieve how it's behaving that way or should the plugin be doing that?
  • I have no idea. 1.9.8.1 is really old.
Sign In or Register to comment.