Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Attachment Folder

Hello and thank you in advance for any help you might provide 
I install osticket 1.9.14 for my store and also i have installed storage-fs.
I create a folder inside osticket folder with permissions 777.
The problem is when i upload an attachment lets say a picture in the folder i can't see the picture instead 
there is a folder with a letter !!!

Any help will be appreciated...

image   
image
image
image
image
image
image

Comments

  • Ticket with attachment ... was created before or after installing, configuring and enabling the plugin?
  • Hi ntozier and thank you for the reply.
    The ticket created after the installing the plugin ...
  • contents of the J folder?
  • empty and you can't put anything inside or rename it, the only thing you can do is to delete 
  • Searching the forum i saw that other people also have the same problem....

    Maybe is some kind of bug ?
    Is there anything wrong in my server ?

    I don't know where to look and what to search ...
  • This sounds like a permission issue.  Does the web user that your webwserver run as have permissions on the folder?  Does the PHP temp upload folder also have the same permissions?
  • yes the user is admin and the folder permissions are 777 ....
    Ashampoo_Snap_2016.09.28_16h57m47s_001_.png
    1641 x 641 - 130K
  • And the temporary upload folder?
  • ???????????????? say what ???
    where is this ???
    :-) :-)
  • We would have no way of knowing where that would be.  its in your php.ini.

    It is my understanding that the way PHP works is when you upload a file, it is put into a temporary folder.  This folder if configured by you, the system administrator, or the host.  When the file finishes uploading PHP moves it to the desired target location.  If PHP cannot write to its own temp folder or cannot read the file after you would get the result that you are describing.
  • I'll contact my host ...

    Thank you

  • My host reply that the increase PHP memory and that the check the temporary upload folder ...
    But i have still the same problem ..
  • Here are some screenshots
    101.jpg
    1598 x 455 - 175K
    Ashampoo_Snap_2016.09.28_19h01m34s_005_.png
    927 x 194 - 20K
  • Ask them if you are running afoul of a mod_security rule.  They can check the logs.
  • ntozier I asked them and their answer is:

    support@hostso.com
    Posted onSep-28th, 2016 19:32


    Hello,

    We would like to inform you that mod_securityis alredy installed on the sever

  • Wow they are so helpful.  Have them check the logs to see if you are running afoul of a mod_security rule.
  • edited September 2016
    hi ntozier they reply that the mod_security rule is running foul !!!
  • Then they will need to fix it.
  • Good day everyone ...

    Today i tried angelo_rm solution but with no luck ...
    from my host informed me that everything works fine ....

    any idea ?

    Thank you in advance
  • At this point I would recommend that you try a different web host.  
  • the problem is still here ... 
    my host can't help me more ...any suggestions ?

Sign In or Register to comment.