Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Upgrade 1.8 to 1.9

I've just setup osticket 1.8git but would like to run 1.9 at least possibly even go to 1.10 I'm not 100% on how to pull version 1.9 or 1.10 from git so I downloaded it from the website and went through the process of backing up the ost-config.php file and then removing my original install and replacing it with 1.9 and putting the ost-config.php file back.

When I then try to load osticket and login to the admin panel to run the upgrade script I just get a blank screen and a 500 error in the browser. If I revert back to the version 1.8 files everything works again. So I'm at a bit of a loss as to why this is happening.

I'm running this on an Ubuntu 16.04 server with only the core elements installed along with ssh, apache, mariadb and php7 ( I subsequently installed php5.6 along side to get cron to work as it bugs out on php 7).

Any thoughts would be great I'd ideally just like to be able to pull 1.9 and late 1.10 from git if possible.


image

Comments

  • You are not running 1.8.  You are running some unknown version downloaded from github.  I do not recognize the commit number (36ee46c7) but my guess is you are running a version of 1.10 already. 

    Why do I guess this?  Well it tells you that 907ec36 is available (which is 1..10rc3) and you are running PHP7.  PHP7 support was not introduced until the 1.10 beta releases.  While you can download from github, it's not the recommended way to get osTicket.

    So I guess my question would be did you actually run the deploy command after getting the code from github?

    It might be easiest if you download the rc3 from osticket.com/download and install that. The stable should be out very soon.  [I'm thinking this week.]

  • Thanks for the response. I've downloaded 1..10rc3 from the website and installed that over my existing installation. I had some trouble initially which appeared to be permissions issues and I have now resolved those.

    I've also downgraded to php 5.6 for the moment and I'll wait for the stable to come out and then upgrade to php7 again.
Sign In or Register to comment.