Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Slow Page Loading on Fresh Install

Mail Sending: SMTP
Mail Fetching: IMAP + SSL
PHP Version: v5.6
Operating System: Server 2012 R2
Staff Side of UI.
Location: all pages

Hi All,

I haven't even rolled out the helpdesk yet, but it seems to be going so slow!
It's taking a long time to load any page (6 seconds +) within OsTicket. I'm sure it wasn't like this during the setup phase.. I must have done something to break it.

Any suggestions on what/where I should start looking at first?

We also have some standard HTML webpages on the same server which load extremely quickly..

Any help would be much appreciated..

Comments

  • edited October 2016
    From my experience, most performance issues are caused by the database. Have you enabled log_slow_queries in mysql? These logs may help to identify what's going on.

    Check your my.cnf for
    log_slow_queries = /var/log/mysql/mysql-slow.log
    long_query_time = 4

  • edited October 2016

    Sounds like you're referring to Linux.
    I think I've managed to enable slow query logging on MySQL.

    It creates the log file, but there's no data in the file apart from this..

    C:\Program Files\MySQL\MySQL Server 5.5\bin\mysqld, Version: 5.5.45-log (MySQL Community Server (GPL)). started with:
    TCP Port: 3306, Named Pipe: (null)
    Time                 Id Command    Argument

  • Please help us to help you by reading and following the posting guidelines located in this thread: Please read before requesting assistance.  The more information you give us the better we will be able to assist you. Thank you.

    Version of osTicket?
    Is your SMTP server on the same local network as the webserver?
    What are the hard ware specs of your server?
  • Apologies, please find information below.

    OsTicket Version: 1.9.14
    Web Server Software: Microsoft IIS 8.5
    MySQL Version: 5.5.45
    PHP Version: 5.6.24

    Yes, SMTP server is on the same local network as webserver.

    Hardware Specs:
    Server 2012 R2 on VMware.
    4GB RAM
    Intel(R) Xeon(R) CPU - X5675 @ 3.07GHz (1 Core, 1 Logical Processor)



  • edited October 2016

    It seems I've identified the issue.

    I've installed the 'reports' mod.
    When I restore the original 'header.inc.php' file, the pages load at much quicker speed.

    I've also added an additional CPU, which didn't seem to improve the issue.


  • We do not support 3rd party addons here.  You should speak to the author of the mod you installed for support.
Sign In or Register to comment.