Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

[resolved] LDAP Authentication and Lookup not working v1.10

Looks like I get HTTP error 500 (in Chrome, Firefox shows blank page) when I try to save anything regarding the plugin, LDAP Authentication and Lookup after I upgraded my installation.

I can't login from the "client" side either, same 500 error.

Any ideas on how to fix this?

Comments

  • Same situation. IIS 8.5 with php 5.6 version.
    With 1.9.15 everithing worked fine.
  • edited November 2016
    I cannot replicate this on my test site.
    I upgraded it to 1.10 and have had multiple agents and users log in using their AD creds just fine.
    IIS 8.5 / PHP 5.6.12

    I also updated some settings in the plugin and saved just in case.

    Lookup on opening ticket however... definitely not working.

  • I'm having issues as well. I just did a fresh install of osTicket v1.10 and I get a blank page when trying to save LDAP settings.

    I'm running IIS 8.5 and PHP 7.0.9.
  • I'm reporting this thread to the devs.


  • Open Ticket (with LDAP plugin) Search in 1.10 results in:
    [02-Nov-2016 21:23:27 UTC] PHP Fatal error:  Access level to Net_LDAP2_RootDSE::__construct() must be public (as in class PEAR) in C:\inetpub\wwwroot\support.110\include\plugins\auth-ldap\include\Net\LDAP2\RootDSE.php on line 238
  • Ok, was thinking of reinstalling the plugin... but I guess I will have to wait for the dev to fix this.

  • Ok, I'll wait the dev. Meanwhile I went back to 1.9.15.
  • @MrDanne reinstalling the plugin won't help.

    @Mayo I didn't upgrade my live site and DB.  I always clone my live site and perform an upgrade on the clone.  But thats probably a good choice.
  • I have a solution.  I posted it on GitHub as a Pull Request.  Here is the link: https://github.com/osTicket/osTicket/pull/3456

  • Just tried it and it did not fix it. Still error 500
  • edited November 2016
    Me too... also if I try to reinstall the plugin (downloaded from the site) ad configure it with the right options in fields (the same of working version 1.9.15) and ckick on "save" it shows me a blank page and loses the configurations.
    Hope it will help the devs.
  • Did you remove the whole line on row 87 ?
  • I deleted the entire row. I also made a fresh install on a new IIS webserver: same problems.
  • To be clear you grabbed the new plugin AND removed line 87?
  • Checked my error.log and getting this after trying to login with a ldap account:

    [Mon Nov 07 10:12:26.348433 2016] [:error] [pid 17511] [client 172.18.1.84:52177] PHP Fatal error:  Access level to Net_LDAP2_RootDSE::__construct() must be public (as in class PEAR) in phar:///var/www/NordicIntranet/helpdesk/include/plugins/auth-ldap.phar/include/Net/LDAP2/RootDSE.php on line 0, referer: http://nordic/helpdesk/login.php

    Anything I can do to solve this?
    Maybe Mayo have the same.
  • Hi MrDanne, where I can find the error.log?
  • edited November 2016
    I am yet another person having this same problem.  Weirdly, I got this same 500 error page when I tried to run through the installer for v1.10 and since I could not get past it I went back to v1.9.15 and everything worked fine.  Should also note that this is a clean install of osTicket that is less than a week old.  I could not get the phar file to work with v1.9.15 so I had to grab the files manually from the repository.

    Server Information
    osTicket Versionv1.9.15 (70898b3) —  Up to date
    Web Server SoftwareApache
    MySQL Version5.5.49
    PHP Version5.5.9-1ubuntu4.20
  • I am running Apache, but för IIS check here: https://portal.smartertools.com/kb/a2487/where-are-my-iis-log-files-stored.aspx

    Must be the actual plugin that need to be updated... 

    Would be nice to have this solved.
    I even updated the LDAP2 in my Ubuntu installation, that did not work either.
  • Server Information
    osTicket Versionv1.10 (901e5ea) —  Up to date
    Web Server SoftwareApache/2.4.10 (Ubuntu)
    MySQL Version5.6.28
    PHP Version5.6.4-4ubuntu6.4
    In case needed...
  • Did you download the new version of the plugin?
    Did you then make the change I suggested in the link above?
  • I downloaded the plugin the day I installed the server, that would have been last Thursday or Friday.
  • @glienhard that does not actually answer the question as to if you downloaded the new version...
  • @ntozier I told you the date I downloaded, you tell me if you have posted a new version since that date.  I downloaded the newest version available at the time.
  • @glienhard The new version was released on Thursday.  Which is one of the two days that you downloaded.  Since you do not appear to know when you downloaded and there is no time provided on your download, nor on the release (which I do not post), it is unlikely that I will be able to provide you with an accurate answer as to which version you downloaded. 

    I suggest that you check and make sure that your plugin is version 0.6.3 and that you made the change I linked.  While I would like to assist you in this matter the only person that can tell us what version you downloaded and are running is you.  If you cannot find the version that you downloaded then perhaps you should just re-download the new version and install it. 

    As a side note I have taken steps to make sure that it will be easier for people to find their version number in future releases (should the pull request be accepted by the devs).
  • @ntozier Didn't even know that a new version of the plugin was released.... Did you write that somewhere?

    Anyhow, I downloaded it now and it works perfectly! 

    Thanks
  • @MrDanne
    I personally didn't mention it other than on other peoples threads both here and github (which I obv do not expect you to read).  Maybe I should have the devs (or myself) post a quick little "Plugin Foo version # has been released, please go upgrade" in the announcements section. Good idea!  Thanks.

    I'll mark this thread as closed and resolved.  Please feel free top open a new thread if you have furhter issues. :)
This discussion has been closed.