Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

LDAP Authentication Plugin

@ntozier - The last discussion got closed before I could continue to get assistance.  Since my issue is slightly different, I'm starting this thread.

Thank you so much for posting the update to this plugin.  Unfortunately I do not see it in the GitHub repository.  All three files in the repository are 1-2 years old.  This is probably where my problem is coming from.

I tried to follow the instructions of downloading the phar file and placing it in the include/plugins directory, the server did not see the phar file and I had no indication on the plugins page that there was anything in the plugins directory.  I ended up creating a directory in plugins and downloading the files out of the repository to this folder.  Then the plugins page recognized there was something there and let me access it.

Where did I go wrong?  Thanks for all your help.

Comments

  • Plugins are located at: osticket.com/download
  • @ntozier Thank you.  That is where I downloaded the phar file that didn't work.
  • You can't simply download the source from github and make it work.  There are commands that need to be run to make it work. (see the instructions at https://github.com/osTicket/osTicket-plugins)

    If you downloaded the version from osticket.com/download it is the most recent version and you do not have to do the additional steps.

    If your server is not seeing phars then you must have some setting / security measure that prohibits the sever from accessing phars.  (If I recall correctly php since 5.3 shipped with phar access enabled)

    Server environment?
    Webserver and version?
    PHP and version?
  • Server Information
    osTicket Versionv1.9.15 (70898b3) —  Up to date
    Web Server SoftwareApache
    MySQL Version5.5.49
    PHP Version5.5.9-1ubuntu4.20

  • Phar

    Phar: PHP Archive supportenabled
    Phar EXT version2.0.2
    Phar API version1.1.1
    SVN revision$Id: a5488937a80433d434af6753d3db8517feaf91df $
    Phar-based phar archivesenabled
    Tar-based phar archivesenabled
    ZIP-based phar archivesenabled
    gzip compressionenabled
    bzip2 compressionenabled
    OpenSSL supportenabled

    Phar based on pear/PHP_Archive, original concept by Davey Shafik.
    Phar fully realized by Gregory Beaver and Marcus Boerger.
    Portions of tar implementation Copyright (c) 2003-2009 Tim Kientzle.

    DirectiveLocal ValueMaster Value
    phar.cache_listno valueno value
    phar.readonlyOnOn
    phar.require_hashOnOn

  • I have removed the files that I had.  I downloaded the latest file to include/plugins from http://osticket.com/sites/default/files/download/plugin/auth-ldap.phar

    Checked and it is not showing up on the plugin's page.  I changed the owner of the file to www-data.www.data; that made no difference.  I even tried changing the permissions to 777 and that made no difference.

    I'm open to any suggestions or advice.
  • When you say "Checked and it is not showing up on the plugin's page." what do you mean?  Do you mean that you went to Admin panel -> Manage -> Plugins and clicked on Add New Plugin and it doesn't show up?
  • That is correct, Admin Panel -> Manage -> Plugins -> Add New Plugin, there is nothing listed.


  • Then you are running afoul of something on your server not allowing access to phar files.  I could be mod_security, SELinux, PHP or Apache configuration, bad permissions on the phar, etc.

    You could take the official phar from the download site and un-phar it and use the directory instead if you want (I do) but that wouldn't really solve the issue, it would just treat a symptom.
  • Who should the owner be and what permissions should be on the file?  Admittedly I'm new to the PHP world and have never worked with phar files.  This is the first time I've come across them.  I'm happy to check config files or even un-phar the file for now to get it working.  Any commands to do this and files to check would be greatly appreciated.  Thanks again for all your help so far.
  • We have no way of answering this question.  It's your server (or host), and only you would be able to look and see what user the webserver is running as. You would then want to make sure that the permissions allowed that user to read the file.

    I find it faster and easier to use unphar dot com to unphar things.
  • OK, yet the next step down this long and winding road...

    Answering what user apache is running under is no problem, that is the www-data user.  This user is the owner of the phar file and had rw access to the file.  It's permissions currently sit at 644.

    I did un-phar the file, thank you again for that info.  I have all the files loaded into a auth-ldap directory in include/plugins.  They are all owned by www-data and have permissions set at 666.

    Neither of these are giving me any results on the webpage.

    Next I installed a separate instance of 1.10 to check that out.  During the install, it had a green check next to phar support.  I'm getting the exact same results with the plugins in the 1.10 installation.

    While I know that it must be something on/in the apache or php config, I'm just at a loss as to where to look.  Furthermore, why isn't it reading the un-phar'ed files?  
  • And there is nothing in your Apache or PHP error logs?
  • Nothing recent in the error logs


    I tried to delete the plugin, thinking I could re-add it.  Now I cannot see it at all.  Is this something that is saved in the db and if so can it be cleared out?
  • To manually remove a plugin from osTicket Take a look at ost_plugin.  Delete the entry for that plugin.  But before you do grab the id.Then take a look at ost_config, and remove any lines where namespace = plugin.id.  Where id is the id number from ost_plugin.
  • It appears there must be something in my control panel software, I'm using Sentora.  It is a Cpanel like program.

    I setup another server, installed just LAMP.  Then installed osTicket and it is working perfectly.  Since these are both the exact same versions of Ubuntu, just installing the apache, php, mysql, etc services differently, I'm going to assume that it has to be something in the way the Sentora installer runs.

    Note to any other Sentora users, plugins are not working correctly.

    @ntozier, thanks for sticking with me as I worked through this issue!
Sign In or Register to comment.