Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Cron job

Hi,
I looked through WIki and other posts in this forum and I still need help.
I get an error when running a cron job command to pull emails/tickets on my server:

Fatal error: Only variables can be passed by reference in
/home/wakeupbo/public_html/helpdesk/include/class.plugin.php on line 555

The command I have is: 

*/5****php /home/wakeupbo/public_html/helpdesk/api/cron.php

Comments

  • Please help us to help you by reading and following the posting guidelines located in this thread: Please read before requesting assistance.  The more information you give us the better we will be able to assist you. Thank you.

    Let's start with Admin panel -> Dashboard -> Information?
  • My cron job has stopped working immediately after upgrading as well. We call the cron task through a scheduled task by running the following command

    "C:\Program Files (x86)\PHP\php.exe" -f c:\inetpub\wwwroot\[sitename]\api\cron.php > log.txt

    I changed my logging to debug and there's nothing being logged in the ticket system for the cron job, and the log.txt file is also empty.

    If I enable Fetch on auto-cron, it fetches just fine from all our emails (and logs in the system logs). I tried recreating the scheduled task but no joy

    Server Information
    osTicket Versionv1.10 (901e5ea) —  Up to date
    Web Server SoftwareMicrosoft-IIS/7.5
    MySQL Version5.5.39
    PHP Version5.5.27
  • Fatal error: Only variables can be passed by reference in
    /home/wakeupbo/public_html/helpdesk/include/class.plugin.php on line 555

    The command I have is: 

    */5****php /home/wakeupbo/public_html/helpdesk/api/cron.php
    Capture1.JPG
    955 x 733 - 121K
  • edited November 2016
    from my php error log:


    [12-Nov-2016 13:00:00 America/Chicago] PHP Fatal error:  Only variables can be passed by reference in C:\inetpub\wwwroot\{sitename}\include\class.plugin.php on line 555

    which is the following:

    553        $ignored = null;
    554        if ($r = dns_get_record($sig['hash'].'.'.self::$verify_domain.'.',
    555            DNS_TXT, $ignored, $ignored, true)
    556        ) {

    any ideas? Looks like the same problem that was reported at this link but I don't search any results at github


  • Upgrading my PHP from 5.5.27 to 5.6.24 seems to have resolved this for me.

  • Good for you Blueyeguy :-) I'm with PHP 5.6.27 and it still doesn't work :-(
  • GreezyBacon suggested a patch for me to try, but I haven't had a chance to roll back the php in my sandbox to 5.5 or 5.4. Maybe you could try it and see if it works for you.
Sign In or Register to comment.