Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

[resolved] Reply Separator Tag not visible in Emails

Hi,

I am using osTicket v1.10 (901e5ea) with PHP 5.6.27 hosted in a MAMP 4.0.6 environment installed on Mac OS version 10.9.5.

I have enabled strip quoted reply and it appears to be placed into the mail.
It is shown in the preview of the Email but not in the Email itself (see screenshots) (Note: I have altered the Reply Separator Tag in the two examples to rule this out as a problem).

I have tried this in Apple Mail and T-Online’s Webmailer.

I assume the problem is the same as in timmerk’s thread (Reply Separator Tag not showing up on reply emails to clients) and the reason being described in styloas’s thread (option to show Reply Separator Tag (it is currently style="display:none")).
I have done some research but not found which file(s) needs to be altered in order to make the Reply Separator Tag visible.

Where can I find this/those file(s)? And which line(s) need(s) to be altered?

Additionally I agree with styloa and can’t understand why this is made invisible out of stock. I would think if someone doesn’t want to use it he disables it in the Email Settings and Options completely.

Thank you for your help
Tagged:

Comments

  • I've just seen that the screenshots were not attached…
    Bildschirmfoto 2016-10-12 um 16.19.10.png
    839 x 457 - 72K
    Bildschirmfoto 2016-10-12 um 16.18.56.png
    851 x 110 - 23K
    Bildschirmfoto 2016-10-12 um 15.04.05.png
    358 x 97 - 15K
  • edited November 2016
    My guess is that it is /include/class.mailer.php circa lines: 434-447 (specifically 442):


            // If the message is not explicitly declared to be a text message,
            // then assume that it needs html processing to create a valid text
            // body
            $isHtml = true;
            if (!(isset($options['text']) && $options['text'])) {
                // Embed the data-mid in such a way that it should be included
                // in a response
                if ($options['reply-tag'] || $mid_token) {
                    $message = sprintf('<div style="display:none"
                            class="mid-%s">%s</div>%s',
                            $mid_token,
                            $options['reply-tag'],
                            $message);
                }
  • Hi,

    Thanks for the answer. The suggestion was correct.
    I have changed text in line 442 to "display:block" and it works. Have tested aswell with "display:inline" which works, too.

    Topic can be closed then.

This discussion has been closed.