Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Multiple Errors: DB Errors and PHP Fatal Errors.

Hi, I've done a fresh osticket install and everything went fine but now I get a list of errors (I've enabled display_errors on bootstrap file).
osTicket is installed and I've been able to do some configurations like the language (I've added PT(default) and FR language packs), logos, but now every time I login into the /scp panel (Admin or Agent) I receive 3 DB Errors (on the configured admin email and in osticket System Log).
DB Errors:
DB Error #1146
DB Error #1064
DB Error #1064

In Admin panel I also get an error in tickets and task configurations (at the bottom: Ticket Attachment Settings) and can't view the save or cancel buttons.
"Fatal error: Uncaught exception 'InvalidArgumentException' with message 'List indices should be integers' in /opt/osticket/upload/include/class.util.php:149 Stack trace: #0 /opt/osticket/upload/include/class.forms.php(81): ListObject->offsetExists('message') #1 /opt/osticket/upload/include/staff/settings-tickets.inc.php(218): Form->getField('message') #2 /opt/osticket/upload/scp/settings.php(57): include_once('/opt/osticket/u...') #3 {main} thrown in /opt/osticket/upload/include/class.util.php on line 149"

In Agent panel I also get errors under Tasks:
"Fatal error: Call to a member function instanciate() on null in /opt/osticket/upload/include/class.task.php on line 1479"

And under Tickets:
"Fatal error: Uncaught exception 'InconsistentModelException' with message 'Unable to prepare query: SELECT A1.`closed` AS `closed`, A2.`staff_id` AS `lock__staff_id`, A1.`staff_id` AS `staff_id`, A1.`isoverdue` AS `isoverdue`, A1.`team_id` AS `team_id`, A1.`ticket_id` AS `ticket_id`, A1.`number` AS `number`, A3.`subject` AS `cdata__subject`, A5.`address` AS `user__default_email__address`, A1.`source` AS `source`, A6.`priority_color` AS `cdata__:priority__priority_color`, A6.`priority_desc` AS `cdata__:priority__priority_desc`, A1.`status_id` AS `status_id`, A7.`name` AS `status__name`, A7.`state` AS `status__state`, A1.`dept_id` AS `dept_id`, A8.`name` AS `dept__name`, A4.`name` AS `user__name`, A1.`lastupdate` AS `lastupdate`, A1.`isanswered` AS `isanswered`, B0.`firstname` AS `staff__firstname`, B0.`lastname` AS `staff__lastname`, B1.`name` AS `team__name`, (SELECT COUNT(R0.`id`) AS `count` FROM `ost_thread` Q7 JOIN `ost_ticket` Q8 ON (Q7.`object_type` = 'T' AND Q7.`object_id` = Q8.`ticket_id`) LEFT JOIN `ost_thread_co in /opt/osticket/upload/include/class.orm.php on line 3134"

In the clients page when creating a new Ticket I also get an error (when clicking in "Create Ticket"):
"Fatal error: Uncaught exception 'InvalidArgumentException' with message 'List indices should be integers' in /opt/osticket/upload/include/class.util.php:149 Stack trace: #0 /opt/osticket/upload/include/class.forms.php(81): ListObject->offsetExists('message') #1 /opt/osticket/upload/open.php(33): Form->getField('message') #2 {main} thrown in /opt/osticket/upload/include/class.util.php on line 149"

After searching for the solution I cannot resolve any of these problems.
I read that it could be the language pack but restoring all to english is the same.
I've reviewed all time zones settings....
I've disabled SELINUX, nothing again.....

The funny thing is that in the past I've already installed an older version of Osticket in a friends company and it went flawless, but now I want to install the new version were I work and Puff..... ;)
I apologise for the (veryyyyyy) long post and if there is any errors in my english (not my mother language):P

HELP ME!!! :D

----- WEBSERVER ------------------------

osTicket Version - v1.10 (901e5ea)
WebServer - Apache/2.4.6 (CentOS 7) OpenSSL/1.0.1e-fips PHP/5.6.27
MySQL Version - 10.0.28
PHP Version - 5.6.27

osticketdb Collation - utf8_general_ci

PS: All DB Errors info are in the attachement.

Comments

  • I've missed WEBSERVER is running in Hyper-V.
  • My guess is that you are using the 1.9.x language packs for 1.10 since the 1.10 haven't been released yet.
  • ok, so I'm going to do a fresh install with 1.9.x and post the results.

    I downloaded the language pack and applied them to 1.10 because there is no info if they're determined for a specific version. :P

    thanks
  • It's confirmed, the problem is the language pack.

    I fresh installed 1.9.x with language pack and it's all up and running.

    So do we have a forecast on when the language packs are available for 1.10 version?

    RESOLVED
  • Q: So do we have a forecast on when the language packs are available for 1.10 version?
    A: I was told soon, about a week ago.
  • @blackley
    Did you do a downgrade from 1.10 to 1.9.x? Did it worked?
  • @planetcaravan he said that he did a fresh install.
  • I did a fresh installation on this system but I'm always having problems.
    I did not use any language pack
    Look at theese images


    image




    image
    Screenshot - 28_11_2016 , 17_15_32.png
    512 x 535 - 25K
    Screenshot - 28_11_2016 , 17_16_30.png
    792 x 620 - 28K
Sign In or Register to comment.