Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

DB Error #1064 and #1146, can't even create a Frontend User

Dear Folks!

I have Problems with version 1.10 right after the installation.
I tried it three times. always deleting and rebuilding the database and webserver files.

Details on the server:
Webspace from german hoster strato.de
osTicket-Version v1.10 (901e5ea) — Up to date
Server-Software Apache/2.2.31 (Unix)
MySQL-Version 5.6.33
PHP-Version 5.6.27
there are php-mods missing: intl, APCu (can't fix it)
i also included german language pack


After i filled the forms on the /setup/ page it left me with a blank page. I thought that the routine had accomplished its tasks successfully, since there were no errors shown.
I continued deleting /setup/ and removed write access from /include/ost-config.php.

So far no problems. I could also log in, specify all necessary email options and add a colleague. Password Reset worked as well as sending emails over smtp.

Next step would be to add a Organisation, but the form lacked a field for the organisation name. then there was one organisation "osTicket".
I even tried to add a user, but after i clicked on Add User the backend left me with a rotating loading animation.

The mailsystem sent me multiple error reports as given in the attached txt

Am i doing it wrong?
Hope you can help me ^^

Comments

  • Language packs for 1.10 have not been release yet to my knowledge so you might want to swtich back to English and see if you encounter the same issues.  Once you do if you are still having the same issues then it sounds to me like your host is blocking AJAX calls.  You might want to consult your error log and talk to them.  It's like a mod_security rule or SELinux.

    FYI I do not see any attachments on this thread.
  • edited December 2016
    I switched the language back to English and deleted the de.phar, but some labels are still in German. Same error.

    here's the error-log
    Errormessages.txt
    5K
  • edited December 2016
    Run this manually:

    CREATE TABLE IF NOT EXISTS `ost_ticket__cdata` (PRIMARY KEY (ticket_id)) DEFAULT CHARSET=utf8 AS SELECT entry.`object_id` as `ticket_id` FROM ost_form_entry entry JOIN ost_form_entry_values ans ON ans.entry_id = entry.id JOIN ost_form_field field ON field.id=ans.field_id WHERE entry.object_type='T' GROUP BY entry.object_id;

    Problem is that you had extra comma "SELECT entry.`object_id` as `ticket_id`,  FROM", thus the query failed. Error 1146 is just a symptom of 1064 I believe. 

    This still should be reported to devs though, without investigating further, I can't really say why you have this issue :)
Sign In or Register to comment.