Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

osTicket Upgrade Error

Upgrading from osTicket 1.9.3 to 1.10.

CentOS release 6.5 (Final)
mysql-server version: 5.1.71 
php-version: 5.3.3
apache version: 2.2.15 

Client interface shows:
Fatal error: Only variables can be passed by reference in /var/www/sites/helpdesk/include/class.plugin.php on line 555 Call Stack: 0.0002 654048 1. {main}() /var/www/sites/helpdesk/index.php:0 0.0003 694680 2. require('/var/www/sites/helpdesk/client.inc.php') /var/www/sites/helpdesk/index.php:16 0.0004 719384 3. require_once('/var/www/sites/helpdesk/main.inc.php') /var/www/sites/helpdesk/client.inc.php:21 0.0010 944920 4. require('/var/www/sites/helpdesk/bootstrap.php') /var/www/sites/helpdesk/main.inc.php:23 0.0016 1209104 5. require('/var/www/sites/helpdesk/include/cl

Admin interface shows:
Parse error: syntax error, unexpected '[', expecting ')' in /var/www/sites/helpdesk/scp/tickets.php on line 33 Call Stack: 0.0006 627000 1. {main}() /var/www/sites/helpdesk/scp/index.php:0


Comments

  • edited December 2016
    Installation requirements are hidden under some javascript thingy, so searching the page didnt work and require a browser that could support those features.  very difficult to find requirements anywhere else.  not listed in readme, etc.  
  • I extracted the v1.10 zip onto a server with a new version of PHP and was able to start the installer, which says it requires PHP 5.4.  This is NOT what it says on the download page:


    Someone should update that page to reflect the correct version requirements.
  • Correct 5.3 is too old.
Sign In or Register to comment.