Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Only php5.4-5.5 will work correctly with osticket

edited December 2016 in General Discussions
Any other version of php (5.6 or 7) will not work correctly with osticket. When using php5.6 I get a starttsl error only correctable by downgrading to php5.5. Php7 simply doesn't work.Thoughts to why this might be?

Comments

  • edited December 2016
    This doesn't not appear to be a suggestion or feedback. Moving to general discussion.
    It also is an untrue statement.  We have multiple instances of osTicket running under 5.6, and so do many others.
  • I tend to disagree. It supports 5.6 like Clinton did with the Honduras coup or Benghazi..... With php 5.6 it will run the site, ldap, and most other things, but it will not properly link with the smtp function. I have browsed these forums and the internet for quite a while searching for the solution to the starttls error. It keeps coming back to the php version, in which people suggested editing the php.ini file amongst other php config files. I have done this. In the end the only solution I have found to work was to downgrade to php5.5 or 5.4. If there is workable solution to the starttls error with php5.6 please let me know and how to fix this issue.
  • We use SMTP just fine.  Other people use SMTP just fine.

    If you are having an issue, then I would recommend that you post a thread about it. Include your system configuration information as described in the posting guidelines located in this thread: Please read before requesting assistance. Be sure to include full error messages. The more information you give us the better we will be able to assist you. Thank you.

    I'm closing this thread.

This discussion has been closed.