Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

cron problem after upgrade to 1.10

hey, corn not work. It does not work after upgrading from v1.9.15

Information about my osticket:
image
When i try run from shell

root@web:/var/www/https/helpdesk/osticket# php api/cron.php
PHP Warning:  Declaration of AssignmentForm::render($options) should be compatible with Form::render($staff = true, $title = false, $options = Array) in /var/www/https/helpdesk/osticket/include/class.forms.php on line 4150
PHP Stack trace:
PHP   1. {main}() /var/www/https/helpdesk/osticket/api/cron.php:0
PHP   2. require() /var/www/https/helpdesk/osticket/api/cron.php:17
PHP   3. require_once() /var/www/https/helpdesk/osticket/api/api.inc.php:23
PHP   4. Bootstrap::loadCode() /var/www/https/helpdesk/osticket/main.inc.php:27
PHP   5. require() /var/www/https/helpdesk/osticket/bootstrap.php:198
PHP   6. require_once() /var/www/https/helpdesk/osticket/include/class.user.php:19
PHP Warning:  Declaration of TransferForm::render($options) should be compatible with Form::render($staff = true, $title = false, $options = Array) in /var/www/https/helpdesk/osticket/include/class.forms.php on line 4270
PHP Stack trace:
PHP   1. {main}() /var/www/https/helpdesk/osticket/api/cron.php:0
PHP   2. require() /var/www/https/helpdesk/osticket/api/cron.php:17
PHP   3. require_once() /var/www/https/helpdesk/osticket/api/api.inc.php:23
PHP   4. Bootstrap::loadCode() /var/www/https/helpdesk/osticket/main.inc.php:27
PHP   5. require() /var/www/https/helpdesk/osticket/bootstrap.php:198
PHP   6. require_once() /var/www/https/helpdesk/osticket/include/class.user.php:19
PHP Fatal error:  Uncaught Error: Call to undefined function mysqli_init() in /var/www/https/helpdesk/osticket/include/mysqli.php:28
Stack trace:
#0 /var/www/https/helpdesk/osticket/bootstrap.php(182): db_connect('localhost....', 'osticket', 'passsss...', Array)
#1 /var/www/https/helpdesk/osticket/main.inc.php(28): Bootstrap::connect()
#2 /var/www/https/helpdesk/osticket/api/api.inc.php(23): require_once('/var/www/https/...')
#3 /var/www/https/helpdesk/osticket/api/cron.php(17): require('/var/www/https/...')
#4 {main}
thrown in /var/www/https/helpdesk/osticket/include/mysqli.php on line 28

When i try run php5.6
root@web:/var/www/https/helpdesk/osticket# php5.6 api/cron.php
<b>Fatal Error:</b> Contact system administrator.


Any idea what is wrong? 

Comments

  • You should go and look at your PHP error log and provide the errors from it that correlate to the trace above,
  • OK, fixed the first error, but still was second.

    root@web:/var/www/https/helpdesk/osticket# php5.6 api/cron.php
    <b>Fatal Error:</b> Contact system administrator.

  • still nothing.
  • You tried the suggestions in the thread?
  • Yes, still have error:

    root@web:~# php /var/www/https/helpdesk/osticket/api/cron.php
    PHP Warning:  Declaration of AssignmentForm::render($options) should be compatible with Form::render($staff = true, $title = false, $options = Array) in /var/www/https/helpdesk/osticket/include/class.forms.php on line 4150
    PHP Stack trace:
    PHP   1. {main}() /var/www/https/helpdesk/osticket/api/cron.php:0
    PHP   2. require() /var/www/https/helpdesk/osticket/api/cron.php:17
    PHP   3. require_once() /var/www/https/helpdesk/osticket/api/api.inc.php:23
    PHP   4. Bootstrap::loadCode() /var/www/https/helpdesk/osticket/main.inc.php:27
    PHP   5. require() /var/www/https/helpdesk/osticket/bootstrap.php:198
    PHP   6. require_once() /var/www/https/helpdesk/osticket/include/class.user.php:19
    PHP Warning:  Declaration of TransferForm::render($options) should be compatible with Form::render($staff = true, $title = false, $options = Array) in /var/www/https/helpdesk/osticket/include/class.forms.php on line 4270
    PHP Stack trace:
    PHP   1. {main}() /var/www/https/helpdesk/osticket/api/cron.php:0
    PHP   2. require() /var/www/https/helpdesk/osticket/api/cron.php:17
    PHP   3. require_once() /var/www/https/helpdesk/osticket/api/api.inc.php:23
    PHP   4. Bootstrap::loadCode() /var/www/https/helpdesk/osticket/main.inc.php:27
    PHP   5. require() /var/www/https/helpdesk/osticket/bootstrap.php:198
    PHP   6. require_once() /var/www/https/helpdesk/osticket/include/class.user.php:19

    <b>Fatal Error:</b> Contact system administrator.
    root@web:~#




    class.plugin.PNG
    807 x 388 - 70K
  • I would suggest to look into this:

    Had same issue after upgrading to php7, having said that - use at your own risk :)
Sign In or Register to comment.