Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Page returns http header at beginning of page

Hi,

Have an issue where agents see http header information at the top of the page before the actual html code. It shows mainly when the agent logs into scp section and when replying to a ticket. I tried changing to PHP version 7.0.14 but that did not make any difference to this issue. I have a feeling that this is related to the include/class.http.php file but I may be mistaken.  Please help.

System info
Server Information
osTicket Version v1.10 (901e5ea) —  Up to date
Web Server Software Apache
MySQL Version 5.5.46
PHP Version 5.5.38


Here is what shows


0

HTTP/1.1 200 OK
Date: Thu, 24 Nov 2016 20:35:13 GMT
Server: Apache
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Cache-Control: no-store, no-cache, must-revalidate
Pragma: no-cache
Keep-Alive: timeout=5, max=99
Connection: Keep-Alive
Transfer-Encoding: chunked
Content-Type: text/html; charset=UTF-8

950
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
<html lang="en-US">
<head>
    <meta http-equiv="content-type" content="text/html; charset=UTF-8">
    <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
    <meta http-equiv="cache-control" content="no-cache" />
    <meta http-equiv="pragma" content="no-cache" />
    <meta http-equiv="x-pjax-version" content="901e5ea">
    <title>osTicket :: Staff Control Panel</title>
..... 

Comments

  • I've never seen this or had it reported before.
    What version of Apache?
    What web browser are you using?
    Have you tried other browsers?
    Can you upgrade to PHP 5.6 to see if it changes the behavior?
  • Apache 2.4
    Google Chrome, Internet Explorer 11, and MS Edge
    PHP 5.6 made no difference in behavior

    Would like to say that I have not myself seen this happen but all the other agents are seeing this every day. Myself and the other users have not installed any plugin and non-standard add-ons to any of the browsers used.

    Any idea or guess as to what is causing this?
  • edited December 2016
    @brianrandrup Just curious, can you provide a screenshot of what you see? 
  • As a side thought, do you have any plugins installed?
    The devs said that they have never seen the header issue, and though it might be a problem with a plugin.
  • No plugins installed nor any customizations done. Went from 1.9.14 to 1.10

    Attaching screen shot so you can see how it looks
    Udklip.JPG
    1633 x 96 - 40K
  • Do you see this from multiple computers, if so, have you used those same browsers on other computers? 
  • Multiple computers each one using different browsers. Some use Chrome others use IE, and some use Edge. All see this issue.
  • So I know that you do not want to hear this, but you are the only person reporting an issue like this, and I can't think of anything in the product that would cause this.  So I think that the problem is your webserver.  Perhaps it's doing some kind of caching and sending things that it shouldn't be... but I simply cannot reproduce the issue. I would recommend that you talk to your webserver admin(s) and have them temporarily disable caching, flush the caches, and see if that fixes the problem.  Worse case we waste some time, best case we identify what's causing the headers being sent like that.
Sign In or Register to comment.