Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

login page not completely translated

Hi,
i am using your Osticket latest version.
Unfortunately, there is a little bug and Login page is not
completely translated as showing here:

http://easycaptures.com/fs/uploaded/1150/1732650453.png



and here:



http://easycaptures.com/fs/uploaded/1150/5914522604.png



please EXPLAIN in details how i can translate this things.

Already:
- Translated all backend Osticket pages
- Translated all Forms fields
- Translated all email and other things

thanks
Tagged:

Comments

  • Please help us to help you by reading and following the posting guidelines located in this thread: Please read before requesting assistance.  The more information you give us the better we will be able to assist you. Thank you.

    Version of osTicket?

    It appears that you are using some sort of heavily modified version of osTicket that I have never seen before.  I cannot be sure since you did not provide a URL, but that "Sign In" looks an like an image to me.

    The second part appears to be your landing page.
    Admin panel -> Manage -> Pages -> Landing
  • Hi thanks for the answer.
    Please note that i am not using any "heavily" modified version of OsTicket, OsTIcket is still original code.
    Only i am using a customized theme.
    It is a simple thing.
    "sign in" is not an image, it is a regular bootstrap button, please check the code.
    There is anybody programmer on this forum ?
  • So do not answer my question.  You tell me I am wrong.  Okay, I guess you do not want my help.

    There is really no way to "theme" osTicket with out modifying the code currently.  We cannot "check the code" because we do not have your "theme" in place.

    I wish you good luck with your endeavor to further modify your code.
  • @Ivanomino, you do understand this is a community (Open Source). From time to time you may have a developer come in and provide an answer, but it's not a requirement for them. They are working on OSTicket on their own time, providing support after their normal jobs/lives. With that said, you still did not provide any details that are needed to assist you. 

    As ntozier stated, OSTicket does not have options for a theme to just be imported and voila, it works. You have to insert code into different sections of files that are usually in multiple locations of the directory where OST is installed in. The code may be original, but some extra items have been added to modify it's original state. Unless you are using a plugin through a CMS like wordpress or joomla. 
  • ok thank for your answer.
    There is some variables code in Osticket called
    $body and $title.
    This variable are not editable in Backend.
    This maybe is a Osticket bug.

  • Maybe its a bug in the "theme" mod that you are using. Maybe it's a bug in the version that you are using.

    Regardless as long as you have this third party "theme" mod installed and can't answer questions we are unable to assist you.
  • This is answer from theme developer:
    Hi Ivano

    Please excuse the delay
    in replying. This is a side project for me that I do not make money from
    so sometimes other project take priority.

    I've had a look into
    your issues and the 'Sign in' link at the top, there is indeed a bug - a
    typo on my part - it needed to have a uppercase 'I'.

    With
    regards the other issue, from what I can see, this text is identical to
    osTicket core which makes me think either the bug exists in osTicket or
    that piece of text hasn't yet been translated into your language of
    choice.

    I have updated the package for you to download here: http://osticketthemes.com/downloads/osTTc-1.10.zip

    Kind regards, Mark

    -------------------------------
    That's identical to my first post in this ticket.
    PLEASE CORRECT PHP VARIABLE $title and $body (located in login page) that doesn't have any reference in backend and related translations.
    Thanks !

  • I'm not feeling particularly inclined to help you at this point since you still have not answered my questions.

    But I did just install a language pack to attempt to replicate your report. After I install the language pack (Spanish in this case) and I translate my landing page as I indicated to you previously.  When browsing to the site... then click on the Spanish flag.... the login button changes to Spanish as expected, as does the content in the middle of the page.

    I do not see a problem.

Sign In or Register to comment.