Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

[resolved] white page

Hi I have osticket run in localhost work perfectly, I upload my file in my GCE when I try to test the page, it only shows white page, I tried to open error.log /var/log/apache2 , this is the error

PHP Fatal error:  Call to undefined function mysqli_init() in /var/www/html/mysupport/include/mysqli.php on line 28


I also set permission chmod -R 777 /var/www/html/mysupport , but still nothing work.

please help me


Thank you in avdance.

Comments

  • Please help us to help you by reading and following the posting guidelines located in this thread: Please read before requesting assistance.  The more information you give us the better we will be able to assist you. Thank you.

    What version of PHP are you using?
  • @blueyeguy

    PHP -

    PHP 5.6.29-1+deb.sury.org~yakkety+1 (cli)
    Copyright (c) 1997-2016 The PHP Group
    Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies
        with Zend OPcache v7.0.6-dev, Copyright (c) 1999-2016, by Zend Technologies

    MySQL -

    Ver 14.14 Distrib 5.7.16, for Linux (x86_64) using  EditLine wrapper


  • edited January 4
    the error says in firebug internal server error
  • Please ensure that your php.ini hasthe php_mysqli extension enabled.  Then restart your webserver software.
  • @blueguy

    [Wed Jan 04 16:32:23.484313 2017] [:error] [pid 23324] [client 10.193.119.4:63875] PHP   2. require() /var/www/html/mysupport/index.php:16
    [Wed Jan 04 16:32:23.484349 2017] [:error] [pid 23324] [client 10.193.119.4:63875] PHP   3. require_once() /var/www/html/mysupport/client.inc.php:21
    [Wed Jan 04 16:32:23.484385 2017] [:error] [pid 23324] [client 10.193.119.4:63875] PHP   4. Bootstrap::connect() /var/www/html/mysupport/main.inc.php:28
    [Wed Jan 04 16:32:23.484463 2017] [:error] [pid 23324] [client 10.193.119.4:63875] PHP   5. db_connect() /var/www/html/mysupport/bootstrap.php:182
  • @ntozier,

    I followed your suggestion but still no luck, I tail the error.log

    include/mysqli.php on line 28
    [Wed Jan 04 16:32:23.484313 2017] [:error] [pid 23324] [client 10.193.119.4:63875] PHP   2. require() /var/www/html/mysupport/index.php:16
    [Wed Jan 04 16:32:23.484349 2017] [:error] [pid 23324] [client 10.193.119.4:63875] PHP   3. require_once() /var/www/html/mysupport/client.inc.php:21
    [Wed Jan 04 16:32:23.484385 2017] [:error] [pid 23324] [client 10.193.119.4:63875] PHP   4. Bootstrap::connect() /var/www/html/mysupport/main.inc.php:28
    [Wed Jan 04 16:32:23.484463 2017] [:error] [pid 23324] [client 10.193.119.4:63875] PHP   5. db_connect() /var/www/html/mysupport/bootstrap.php:182

  • mysqli_init() is a PHP function.  So if your PHP is telling you "Call to undefined function mysqli_init()" then your PHP does not have the extension enabled.
  • @ntozier,


    Hi thank you for the reply,

    what about this errors

    include/mysqli.php on line 28
      2. require() /var/www/html/mysupport/index.php:16
      3. require_once() /var/www/html/mysupport/client.inc.php:21
       4. Bootstrap::connect() /var/www/html/mysupport/main.inc.php:28
      5. db_connect() /var/www/html/mysupport/bootstrap.php:182
  • Thats not an error, its an error trace, and appears to be for the error that you already reported.
  • @ntozier,
     
    why I am still having with white page ?


    Thank you in advance.
  • Did you modify your php.ini to include the extension? [Are you sure that you modified the correct php.ini if you have more than one version of PHP installed?]
    Does your server have the extension on it (ie did you install it)?
    Did you restart your webserver software?

    If your answers are Yes to those, then I have no idea.  But there appears to be a problem with your PHP on your server that it thinks that mysqli_init() is undefined.  You will have to troubleshoot that.
  • @ntozier,

    yes I modified in /etc/php/5.6/apache2/php,ini

    i also check default php is being use
     php -v

    and it says php 5.6

    I restart  sudo service apache2 restart


    Thank you in advance.



  • Do you have more than more than one version of PHP installed?
    Have you searched for other php.ini files?
    Have you tried making a test page: with <?php phpinfo(); ?> in it and browsing to it to see if mysqli is enabled?

    NOTE: mysql and mysqli are two different things.
  • @ntozier,

    Thank you so much the pain is over... I solved it thank you for the idea to troubleshoot. :)
  • So what ended up being the problem?
  • edited January 11
    Hi @jemz,
    What was your solution to the problem? I have the same...
  • @ntozier , @henninga,

    I apologize for late reply..my solution is to purge the php 7.0 because the server use the php 7.0 . so to make sure only php5.6 is used I delete the php7.0.


    Thank you.
  • Thanks for posting what your fix was. :)  I've marked this respolved and closed it.
This discussion has been closed.