Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Failed Update from 1.9.12 to 1.10

Hi All,

I'm getting an error when attempting to upgrade OSTicket from 1.9.12 to 1.10, with the following error:

Error Log:
[/** * @signature 1ee831c854fe9f35115a3e672916bb91 * @version v1.10.0 * @title Make editable content translatable and add queues * * This patch adds support for translatable administratively editable * content, such as help topic names, department and group names, site page * and faq content, etc. * * This patch also transitions from the timezone table to the Olson timezone * database available in PHP 5.3. */ ALTER TABLE `ostick_attachment` ADD `lang` varchar(16) AFTER `inline`] Duplicate column name 'lang'

I am not seeing a column 'lang' under osticket_attachment'

I've also tried to upgrade from 1.9.13 and 1.9.14 and received the same error.

Any help would be appreciated
imageimage

Comments

  • Please help us to help you by reading and following the posting guidelines located in this thread: Please read before requesting assistance.  The more information you give us the better we will be able to assist you. Thank you.

    What version of PHP are you running? 
    Quoting @ntozier "I would recommend that you use php 5.6, 5.3 will not work, 5.4 and 5.5 might work but have security issues because they already have reached their end of life."

  • OK Ignore my comment, your attachments didnt come through for me until after I opened my mouth.

  • So the error you are getting appears to be:  
    ALTER TABLE `ostick_attachment` ADD `lang` varchar(16) AFTER `inline`] Duplicate column name 'lang'

    This says that the upgrader is trying to add a column to the table and the MySQL says it already exists.  

    Did you try to upgrade in the past and have it fail? 
    Can you provide a screen shot of the columns in your ostick_attachment table?
  • The lang column doesn't exist.  I thought maybe the 'created' column was causing issues, so I also tried to delete the table, and recreate so that only the 'attached_id,ticket_id,field_id,ref_id, and inline' columnes, but it still fails.

    I have tried to upgrade with the same failure before, but I refreshed the db with a mysqldump before attemping upgrades.
    osticket_db.jpg
    1039 x 890 - 779K
  • Your image shows us the ostick_ticket_attachment table.  
    Not ostick_attachment.  The error specified the ostick_attachment table.
  • Sorry, here you go.
    osticket_db1.jpg
    887 x 682 - 287K
  • Presuming that your looking at the right database I have no idea why your MySQL is telling you the column already exists...
  • I refreshed DB and tried again, and came up with a different of errors:







    p.p1 {margin: 0.0px 0.0px 0.0px 0.0px; font: 14.0px Calibri; -webkit-text-stroke: #000000}
    span.s1 {font-kerning: none}

    [CREATE TABLE `ostick__unknown_inlines` AS SELECT A2.`attach_id` FROM `ostick_file` A1 JOIN `ostick_ticket_attachment` A2 ON (A1.id = A2.file_id) JOIN `ostick_ticket_thread` A3 ON (A3.ticket_id = A2.ticket_id) WHERE A1.`type` LIKE 'image/%' AND A2.inline = 0 AND A3.body LIKE CONCAT('%"cid:', A1.key, '"%')] Statement violates GTID consistency: CREATE TABLE ... SELECT.

  • Any other suggestions?
  • I have never seen the error "Statement violates GTID consistency" before, so no.  I would presume that something in MySQL 5.7 is borking things.  I do not know anyone who runs that version.  I would recommend downgrading to a pre 5.7 version of MySQL or MariaDB and see if that fixes your issue.
  • edited February 10
    I have the same error in the MySQL DB from googlcloud.
    They have changed the enforce_gtid_consistency value to true.
    http://stackoverflow.com/questions/37995391/set-enforce-gtid-consistency-back-to-false
    https://dev.mysql.com/doc/refman/5.6/en/replication-options-gtids.html
  • Mysql 5.6.9 , in 5.7 it is the default.
Sign In or Register to comment.