Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Error 500 - osTicket v.1.10

Hi everybody,
I'm a beginner in PHP I've some knowledges.
I've installed the osTicket v1.10 901e5ea with no plugins, I've changed nothing in the osTicket source files and I can't open tickets, it sends me an error 500 when I use this url :

I've looked around for an issue but nothing's happen, I've tried to change the PHP version (I'm actually with PHP 5.6.25 and I've tried with PHP 7.0.10) I've tried to remove the language pack (fr.phar)

My WAMP64 version ->  3.0.6
My Apache version -> 2.4.23
My MySQL version -> 5.7.14

The php_error.log : 
[24-Jan-2017 08:19:24 UTC] PHP Fatal error:  Uncaught exception 'InvalidArgumentException' with message 'List indices should be integers' in C:\wamp64\www\sites\osTicket-v1.10\upload\include\class.util.php:149
Stack trace:
#0 C:\wamp64\www\sites\osTicket-v1.10\upload\include\class.forms.php(81): ListObject->offsetExists('message')
#1 C:\wamp64\www\sites\osTicket-v1.10\upload\include\class.ticket.php(3756): Form->getField('message')
#2 C:\wamp64\www\sites\osTicket-v1.10\upload\scp\tickets.php(328): Ticket::open(Array, Array)
#3 {main}
  thrown in C:\wamp64\www\sites\osTicket-v1.10\upload\include\class.util.php on line 149

image
Thank you for your help

Comments

  • FYI Localhost is only able to be seen by you, it's not an external link anyone can see.

    As to your issue, did you make any modifications? Are you sure WAMP was installed correctly?
  • I noticed that you tagged this conversation 1.10-rc.2.  Are you actually running rc2?  If so then you should get the final from osticket.com
  • Hi,
    @Synt4xError, I've tried to re-install wamp and re-install osticket 1.10 from scratch and it's work fine now... I don't know why, because I've changed nothing on the osticket files sources only on apache (for oldest version of osticket).
    @ntozier, I don't know, I've downloaded last week at this address http://osticket.com/download and the only tag with osticket 10 was with the rc2...
    Thank you for your help
  • There is nothing on 
    that says anything about rc2.


  • I mean, with the tags, I didn't know what choose and I've chose the rc2 ^^
    image
  • I see.  Well your not using the DPR (Developer Preview Release) or the RC (Release Candidate) if you downloaded the version at osticket.com right now.

    I would downgrade to MySQL 5.6 and see if that helps.  Several people have reported issues running 5.7.  
Sign In or Register to comment.