Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Documents added to ticket disappear on edit

Hi there,

I'm running v1.10 (901e5ea) on a Win 7 Virtual Machine, with a XAMPP for Windows install v3.2.2, with Apache /2.4.23 (Win32) Open SSL /1.0 2h PHP /5.6.24  MySQL v10.1.16.

I have configured the system to use File System attachments and have LDAP enabled but it isn't working at the moment (need to get some search base and schema information from our Infrastructure team).

At the moment, we use this system as a fully internally facing system managing complaints......our internal team receive complaints via email or letter, they create a ticket with the appropriate details and this is then allocated to a team.  The complaint handler then takes the ticket from the workqueue, checks the details and triages the ticket.  They then add a form to the ticket called Triage and add further details of initial actions they have taken, such as called the complainant or attach a letter which they have sent.  The idea is that this would resolve the complaint and then the complaint handler would then add a third 'form', Level 1 Closure, which details that the complaint has been handled to the complainant's satisfaction.

What is happening is that when the handler goes into Manage Forms and adds the Triage form to the ticket, the attachments disappear from the ticket.  If I go into the ticket and edit any of the fields, the documents persist. However, the action of editing the triage form has deleted the documents from the ticket which makes it impossible for any further action to be referred back to the initial complaint.  Adding an internal note with a document doesn't affect the ticket, but adding a document to the triage portion then going back and re-adding the original documents to the Complaint Details form portion of the ticket removes any document added to the Triage portion.

I've attached a document showing screenshots.  What I'm looking to happen is for the documents added to the ticket portion to persist as there doesn't seem to be any kind of delete even happening, it's as if the ticket is simply losing the hyperlink connection to them.  Is this possibly due to the file system storage as opposed to database storage of documents?

Thanks for the consideration.

Regards,

Chris Campbell

Comments

  • image
    Tried to upload screenshot documents....didn't seem to work?
    Initial creation of ticket.docx
    276K
  • So I have to admit that was really long and I only skimmed it.  So before I go back and actually read it I have some questions for you.

    1.  Since you are using the Authentication::LDAP plugin under 1.10 have you applied the Fix in this thread (and the one in the linked thread)?

    2. Are you married to XAMPP?  I ask because over the years many people have reported some REALLY wonky issues when using XAMPP and the best I narrowed down was due to its default settings.

    3. Since you are using the Attachments: Filesystem plugin have you tried shutting it of and seeing if the same behavior happens?  I've personally not seen this behavior and so I'm wondering if there is a problem with the plugin in 1.10.  What version of the Attachment::Filesystem plugin are you running?

    4. Have you looked at your PHP error logs to see if there are any errors being logged?
  • Please try to block out your personal details (email/full name) from your images, it seems very sensitive to have it shown on the forums publicly.
Sign In or Register to comment.