Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Some characters are creating problems

Hi there,

I've noticed that the sue some character is creating some problems.
Example 1: Put < charcater inside internal note:

On internal note's subimt become:

Example 2: Put multiple words in cusomers "Full Name":

On submit become:

Here is my configuration:



  • edited February 2017
    Hello, I do not understand what is the problem you are describing. 

    E-mail address is linked to the account, which has forename lastname(aka surname), if you put other stuff in the name field, it will most likely pick the correct ones from the account. You would want to edit existing users account to change name if you need to.

    Or maybe I just don't understand the issue :)

    P.S. Indeed if you put "<" aka &lt symbol in the internal notes/post reply, everything after this symbol gets removed on the line, but not after. I have noticed this behaviour before too and just double checked it. Most likely a bug with the editor. :)

    Found it on GIT:
  • Problem is not on email linked to the account. The system is alweys cutting multiple words using as Name field!
    It's very simple:
    You enter ONE TWO THREE
    System will show: ONE THREE
  • edited February 2017
    And how is your user configuration? 
    The name for the user is ONE TWO THREE and it is cutting it to ONE THREE 
    The name for the user is ONE TWO and you try to write ONE TWO THREE and it is still cutting it to ONE THREE? :)

    As I said before, I think the system is looking up the users name from the database based on e-mail address you enter and matches the correct record saved for the user in ost_user. But it is a wild guess, would need to check the code.

  • The name for the user is ONE TWO THREE and it is cutting it to ONE THREE
  • I have tested it and indeed it is the case, it does write first and last name from several given the chance. 

    Even in user list it shows this behaviour, thus I would conclude that it is the expected behaviour of osTicket to expect to have only Forename and Surname and no middle-names, probably because of limitations.

    @ntozier can help further with what to do, but judging from I have seen is:
    1) &lt issue won't be fixed as per git ( )
    2) Having two one forename and one surname is the expected behaviour

    Sorry for not being able to help you more with these problems.

  • I think the correct behaviour is to truncate nothing!
    It's not a matter of first or second name... The name field could also be used as a company name with three or more words....
  • I think that the correct behavior is for you to configure your system the way you want it to behave.

    Admin panel -> Settings -> Agents 
    Change "Name Formatting" to -- As Entered --.

    Admin panel -> Settings -> Users
    Change "Name Formatting" to -- As Entered --.
  • Thanks ntozier. I did not imagine something like that.
    The problem in my Example 1 remains
  • < and > are HTML reserved characters.  They are being stripped by the WYSIWYG editor before being inserted into the DB.
  • Hi,
    We are also having a problem with angular brackets <> around text in the body section.

    When emails are forward from our email clients like Thunderbird or Outlook to our osticket email account (GSuite) all email addresses between < > in the right side of the person name are cleaned from the Forward section of the body.

    This is a big problem because the agent that is going to work on the ticket has no longer access to the email of the person who started the contact with us.

    Is there a workaround or fix? This started when we upgraded to version 1.10. Now we have 1.10.1.

    PS: planetcaravan sorry to hijack your topic
  • This is a massive problem as it is also impacting ANY database fields...Our clients send us passwords and sometimes they contain those characters. Is there a way to fix this? I've attached a video:
  • Hi @planetcaravan, I ran into the same Issue considering brackets the other day and found a workaround:

Sign In or Register to comment.