Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

1.10 - Auto respond to ticket submitted by e-mail

OSTicket 1.10
RHEL 7.3
httpd 2.4.6
MariaDB 5.5.52
PHP 5.4.45

I have got OSTicket set up where, if a user submits a ticket by going to the website, they are automatically sent a confirmation e-mail: "Support Ticket Opened [#123456]"; here are my autoresponder settings:

New Ticket:     Ticket Owner
New Ticket by Agent:     Ticket Owner
New Message:     Submitter: Send receipt confirmation
Participants: Send new activity notice

If a user submits a ticket via our e-mail address specified in E-mails --> E-mails, a "New Ticket Alert" is automatically e-mailed to me, so I can tell the server is able to send out e-mails.

I'm looking for a very specific functionality, as 99% of tickets are submitted via e-mail: when a user e-mail submits a ticket, OSTicket should automatically reply to the sender with a ticket number and link, as if they had submitted it via Web.

Thoughts?

Thanks!

Comments

  • Was there a specific question in there? It sounds like you just said it is doing what you want it to do.


  • Sorry about that.

    The functionality I'm seeking that I cannot get it to do is to automatically send confirmation e-mail to users when they submit a ticket via e-mail.
  • Under Admin Panel > Emails > Emails > [your email address]

    Do you have Auto Response: Disable for this Email Address   checked?

  • You can also check auto response options for your Help Topics

    Admin Panel > Manage > Help Topics > [your help topic] > New Ticket Options 

    Auto Response:Disable new ticket auto response
  • I have both of those "Disable" boxes unchecked.
  • Are you using any ticket filters that might be set to disable auto response?

  • also check the department level.
  • I've checked all the following:

    1. Admin --> Manage -> Help Topics ->
    (each help topic) -> New ticket options Tab -> Ensure Disable
    ticket auto response
     
    is NOT checked.

    2. Admin --> Emails -> Settings ->
    Default Template Set (ensure this is setting exists and is set)

    3. Admin --> Emails -> Templates ->
    Ensure status is enabled.

    4. Admin -> Settings -> System ->
    Autoresponder Tab -> Ensure all New Ticket and New Message boxes
    are checked.

  • you didn't list   Admin Panel > Emails > Emails > [your email address]
  • In Admin Panel --> Emails --> help@dept.example.edu I have Auto-Response Disabled unchecked. Here's how I have e-mail set up:

    Email address: help@dept.example.edu
    Username: dept-ticket@example.edu
    IMAP server: outlook.office365.com
    Port 993

    help@dept.example.edu is a distribution list that goes to dept-ticket@example.edu plus myself [this way, I see ticket the instant they come in rather than after OSTicket's once-a-minute cronjob]. OSTicket checks "dept-ticket@example.edu", a service account in Office 365.

    Could this be a problem? That the e-mail address is different from the username?

    Our SMTP server is mailrelay.example.edu:25, which is an open-access, no-authentication SMTP server run by our university's central IT for use on PDF scanners and web apps.
  • Have a read through https://github.com/osTicket/osTicket/issues/726 for background and workaround

    TL;DR The problem is the x-auto-response-suppress header on distribution lists
Sign In or Register to comment.