Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

[resolved] Duplicate ticket after applying filter

Brand new 1.10 install on Ubuntu 16.04. I have polling of an email address setup to create tickets. I have a single filter (priority 1) that says if user data->email address = "some@email.com" use action use reply-to address. Now I am getting two tickets opened, one with the filter applied and another with the original email address. 

I have also tried modifying the filter to use user information->email"some@email.com" action use reply-to address with the same result.

What's going on and I can I troubleshoot it?

Thanks,
Avi

Comments

  • Please help us to help you by reading and following the posting guidelines located in this thread: Please read before requesting assistance.  The more information you give us the better we will be able to assist you. Thank you.

    I can think of a number of things that could cause this.

    1. you have multiple pollings setup. (perhaps activity on staff checked, and cron)
    2. You do not have delete or move emails setup after fetch.  So the first ticket was created, then after you added the rule the email got checked again and created a second ticket since you told it to use a different email address.

  • Ahh, the second is the problem. Thanks so much!!
  • Very welcome. :)

    I'll mark this as resolved and close it..  Feel free to start another thread if you have another quesiton.
  • edited February 23
    Spoke too soon, still having issues.

    The email is now set to move messages to a folder, but it's still creating two tickets when I retrieve a single email from that address. One with and one without the reply-to filter. Interestingly, if I send multiple emails to the address only one message has the filter applied (still creates two tickets), the rest do not.

    I have cron setup to run every 5 minutes and I set the email preferences to fetch via IMAP (Gmail account) every 5min. 

    • There are no PHP errors in the log
    • Mail Sending: SMTP
    • Mail Fetching/Receiving: IMAP (Gmail)
    • PHP version 5.6 ( 5.6.30-1+deb.sury.org~xenial+1)
    • Operating System: Ubuntu 16.04
    • Staff side of the UI

    1.png
    962 x 511 - 40K
    2.png
    969 x 541 - 51K
    3.png
    949 x 953 - 76K
  • edited February 23
    [removed]
  • edited February 23
    [removed]
  • I figured it out! It was email forwarding built into Gmail. Thanks for the help, the discussion can be closed.
  • Glad you figured it out. Closing.

  • <-- smiles happily and goes to tell the devs to never mind looking at this thread. :)
This discussion has been closed.