Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Issues with Custom Queue BETA

I've downloaded https://github.com/greezybacon/osTicket-1.8/tree/feature/custom-queues and added it to my install however when I try to do anything all that is displayed is 

Error: Call to a member function getId() on a non-object 

It says the issue is on line 121 of scp/tickets.php

Does anyone know how to fix this as I would really like to be able to add custom cloumns 

Comments

  • Please help us to help you by reading and following the posting guidelines located in this thread: Please read before requesting assistance.  The more information you give us the better we will be able to assist you. Thank you.

    My guess is that you installed it on a version that you ought not have.
    My second guess is that you did it wrong.
    My third guess is that your version of PHP is higher than 5.6.

  • I've managed to just change the code to display different information.

    Are custom queues coming in a future version?
  • Last I heard it was slated to be released in the 1.11 release.
  • Any idea when that is due out?
  • When it's done.

    (Seriously I know that answer sucks, but the devs do not give release dates and I've lost track of how often people have asked that question).
  • Thats fine, quick question I'm using V1.10 do you know how to delete the 'Assigned To' column, I'm able to add other columns but I cant figure out how to remove that one.
  • I haven't used custom queues or modified the open ticket columns personally.  So I would refer you to the "A better ticket list" thread.

  • I've had a look at that link, but I think I'll try with the BETA, here is my information 

    osTicket Versionv1.10 (901e5ea) —  Up to date
    Web Server SoftwareApache/2.4.4 (Win64) PHP/5.4.12
    MySQL Version5.6.12
    PHP Version5.4.12
    Any idea why I'm getting this error message?
  • I would start with an upgrade to PHP 5.6


Sign In or Register to comment.