Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Auto response on new ticket creation not working

Hi, I know this has already been discussed on this forum but none of the solutions have helped.

When a new ticket is submitted via email to a group email (support@domain) address the auto response mails are not sent to the originating user, the mail is collect (via cron) and a case is created. If the mail is sent to the configured user account's email address the case is created and the auto response mail is sent. If a new ticket is created via the web interface the auto response mails are also sent.

I have checked the following;
  • Tickets- Autoresponder = all options selected
  • Manage - Help Topics = autoresponse enabled
  • Emails - Emails - New Ticket Settings = autoresponse enabled

Mail platform = Google Apps

Server Information
osTicket Versionv1.10 (901e5ea) —  Up to date
Web Server SoftwareApache/2.2.15 (CentOS)
MySQL Version5.5.40
PHP Version5.4.33
Logs are set to Debug but I don't see any errors related to the emails.

any suggestions?

Thanks

Comments

  • Check your PHP logs and try upgrading your PHP to 5.6

  • You also might want to check your mail server logs and see if the email is getting that far also.
  • Hi,

    I need to pick this up again, I upgraded PHP to 7.1.7 but it has not resolved the problem and there are no errors in the logs. Mail logs don't show the mail either. I have also moved from centOS to windows (IIS 7.5)

    Problem is definitely with the group (support@domain) if I mail the user that is configured to fetch the mail or change the email address to that user, then the auto-response mails get sent.
  • osTicket does not support PHP7.1+ yet.  You should use 5.6 or 7.0.
  • Hi,

    Still no luck with either version, Case Creator does not receive auto-response mails.
  • Is your group email setting a header that indicates it is a bounce or auto-reply? Because osTicket won't send auto notifications to those messages to prevent email loops.

    You said Google groups?
    I checked, yes, it sets header:
    Precedence: list
    Which triggers isAutoReply here:
    https://github.com/osTicket/osTicket/blob/405b909209c0b9b6fd4f31963c38ed5f22537e5c/include/class.filter.php#L813

    So osTicket thinks that the email is an automated message already and tries to play nice with the other software.

    If you think about it, an auto reply to the group would send a message to everyone in the group.. probably not what you want. Especially if it then triggers a response to osticket triggering another Auto response.. . Etc, until Google cut you off or your server fills up with tickets.

    If it is what you want, and you use g-suite, you could strip that header for that recipient from the mail envelope via the admin console (advanced magic), or modify the code to ignore that header.. or maybe not use the group, just use tickets, it's what we did at my company, much better.

  • Hi Grizly,

    Thanks for your response, auto reply should not go to the group but to the external individual that logged the ticket, so it shouldn't create a mail storm? I tried the solution above by commenting out the "offending" line but this also did not solve my problem

    would you mind elaborating on your solution to either strip the header info (advanced magic :) ) or to use "tickets"
  • Wouldn't the original sender be occluded by the group email address?
    Eg: Help.me@ext.org => group@company.tld => tickets@company.org
    Therefore the ticket is created for company-group@googlegroups.com or similar?

    But you raise an interesting use-case. I've a solution in mind, needs to get my tools (my code is at work).
    Essentially, we can use my rewriter plugin to change the sender to the original by changing the headers!

    https://github.com/clonemeagain/plugin-fwd-rewriter I'll have a look in a few hours (it's 0643, I try not to code this early). But if you're sufficiently caffeinated and willing to try, it's a public repo, make a pull request.

    The dark magic? Well, I call it that because the settings are dangerous.
    https://support.google.com/a/answer/1346934?hl=en

    Basically you can use the content compliance Configs to change things.. even headers.
    However, if you've tried commenting out the check, and it didn't work, then it's not that! So don't go breaking your whole email system on a hunch by some forum weirdo (me).

    Maybe check your outbound email logs, perhaps it is sending it, but the group is ignoring it because the ticket system isn't a posting rights member?
  • Actually, apart from that header, it shouldn't trigger.. and my G-Suite email headers appear to correctly set the "From: originalsender@mycompany.com". 

    Do the tickets get created in a department that has Autoresponder disabled? It's a separate setting from the one's you've checked.

    Well, assuming the department is different for these group emails I suppose. 

    Hmm, what if Google is doing the same thing? What if they are filtering AutoReplies!?!

    YES THEY DO:
    Appears to have been an issue for a while: https://github.com/osTicket/osTicket-1.7/issues/609

    Those are now found in /include/class.mailer.php lines 397 https://github.com/osTicket/osTicket/blob/develop/include/class.mailer.php#L397.

    But you'd only want to remove those for that particular recipient.

    I just checked on mine, the headers it adds for autoresponse: 
    X-Auto-Response-Suppress: OOF, AutoReply
    Auto-Submitted: auto-generated
    Maybe try commenting that out and try again. Or we'd have to add a Signal to mailer so we can edit them before they are sent.. irritating. 
Sign In or Register to comment.