Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

"This action requires a lock. Please try again" when trying to post reply to ticket

v1.10 (901e5ea)

I recently updated my production site to V1.10 (tested a few basic features - all looked good) and have had the first clients production ticket come through since the upgrade. I am unable to reply to it, with a red error appearing above the 'To:' field saying '
This action requires a lock. Please try again '
I have disabled Lock Sematics under Admin > Tickets > Settings. But I only did that after I saw this error.
I can't add an internal note either. I'm stuck.

The issue persists.
I am the only one logged in.

Its unclear what this error means or how I can resolve it....?


  • What version of PHP are you running? Several users have reported issues after upgrading to 1.10 until upgrading to PHP 5.6
  • edited March 2017
    I'll try that. thanks.
    osTicket Version

    v1.10 (901e5ea)
    Up to date
    Web Server Software Apache/2.4.25
    MySQL Version 5.6.33
    PHP Version 5.4.45
  • edited April 2017
    Hmm unfortunately that hasn't helped.

    After a PHP upgrade I have the same behaviour.
    Server Information

    Sorry for the whitespace.. I can't seem to remove it
    osTicket Version v1.10 (901e5ea) — Up to date
    Web Server Software Apache/2.4.25
    MySQL Version 5.6.33
    PHP Version 5.6.30
    PHP Extensions
    gdlib Used for image manipulation and PDF printing
    imap Used for email fetching
    xml XML API
    xml-dom Used for HTML email processing
    json Improves performance creating and processing JSON
    mbstring Highly recommended for non western european language content
    phar Highly recommended for plugins and language packs
    intl Highly recommended for non western european language content
    fileinfo Used to detect file types for uploads
    APCu Improves overall performance
    Zend Opcache Improves overall performance
    PHP Settings
    cgi.fix_pathinfo "1" is recommended if AJAX is not working
    date.timezone UTC
    Database Information and Usage
    Schema osticket (localhost)
    Schema Signature 98ad7d550c26ac44340350912296e673
    Space Used 43.20 MiB
    Space for Attachments 42.95 MiB
    Timezone MST (Interpreted as America/Denver)

  • I've found a work around by setting

    Collision Avoidance Duration: 0 (Disabled)

    Although I would like to re enable this feature without the bug.

  • Check your timezones.  All of them.
    Mysql Server, MySQL DB, Webserver, PHP, osTicket, profile.  Make sure that they match.
  • I want to append more information about this issue, 

    yesterday the summer time has ended, and we late the time 1 hour. all computers, servers has the correct hour, but, when a ticket is opened the ticket open time has 1 hour less.
    for example, with the "new" hour is 10:00 am (in summer time was 11 am) and the ticket has the 9:00 am time.

    now when I'm trying to reply or close a ticket I received that message and in the top window shows an message with a kangaroo saying that the lock will be expire soon, if I want to renew, I clicked on Renew button but nothing happened.

    Server Information
    osTicket Versionv1.10 (901e5ea)  Upgrade— v1.10.1 is available
    Web Server SoftwareApache/2.4.12 (Win32) OpenSSL/1.0.1l PHP/5.6.8
    MySQL Version5.6.24
    PHP Version5.6.8
    PHP Settings
    cgi.fix_pathinfo "1" is recommended if AJAX is not working
    date.timezone America/Mexico_City
    Database Information and Usage
    Schemahelpdesk (localhost)
    Schema Signature98ad7d550c26ac44340350912296e673
    Space Used116.67 MiB
    Space for Attachments93.83 MiB
    TimezoneCentral Standard Time (Mexico (Interpreted as America/Chicago)
  • edited October 2017
    This github PR looks like it would solve many of the timezone problems:

    I created a github issue for a similar but different issue and there is a quick 1 line fix mentioned too:
  • Also make sure that all your timezones match ever where.
Sign In or Register to comment.