Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

[resolved] Many features works if accessed through Mobile Browser else gives error

Hi,

Many features gives error if accessed through Chrome or Firefox on laptop but are accessible via mobile.
  1. Task Creation
  2. Change User
  3. Delete User
  4. Number Sequence, infact gets sql error if access through laptop, pfa db error details

[INSERT INTO `osti_sequence` SET `name` = 'New Sequence', `current` = '1', `increment` = '1', `padding` = '0']

Unknown column 'current' in 'field list'


---- Backtrace ----

#0 (root)/include/mysqli.php(204): osTicket->logDBError('DB Error #1054', '[INSERT INTO `o...')

#1 (root)/include/class.orm.php(3133): db_query('INSERT INTO `os...', true, true)

#2 (root)/include/class.orm.php(597): MySqlExecutor->execute()

#3 (root)/include/ajax.sequence.php(99): VerySimpleModel->save()

#4 [internal function]: SequenceAjaxAPI->manage()

#5 (root)/include/class.dispatcher.php(145): call_user_func_array(Array, Array)

#6 (root)/include/class.dispatcher.php(38): UrlMatcher->dispatch('manage', Array)

#7 (root)/include/class.dispatcher.php(120): Dispatcher->resolve('manage', Array)

#8 (root)/include/class.dispatcher.php(38): UrlMatcher->dispatch('/sequence/manag...', NULL)

#9 (root)/scp/ajax.php(262): Dispatcher->resolve('/sequence/manag...')

#10 {main}

Pls let me know what could be the possible reason ...


Server Information











osTicket Version v1.10 (901e5ea)
Up to date
Web Server Software CentOS 7: Protected by Mod Security
MySQL Version MariaDB 10.1.21
PHP Version 5.6.30

Comments

  • mod_security.... disable it and see if your problem disappears.
    SELinux same deal.

    If your issue disappears then you have the culprit. (make sure that you re-enable them afterwards)
  • HI,

    Done but issue still persists, I've earlier also checked the mod security logs but there were none, tried switching off firewall too.

    Infact if u see in all these operations are done through POP WINDOW, which is causing an issue. Any clue.
  • Than I have no ideas what your problem could be. 
    Nor do I have any idea what you mean by "POP WINDOW".
  • Pop Up Window -

    A window that suddenly appears (pops up) when you select an option with a mouse or press a special function key. Usually, the pop-up window contains a menu of commands and stays on the screen only until you select one of the commands. It then disappears.
  • If you have having issues with pop up windows then the you definitely have a SELinux or mod_security issue.  They are made with an AJAX call.
  • hi, both are disabled.

    Still, problem persists.

    Using NGINX as a reverse proxy with varnish. Also, memchache.
  • Then it could be your proxy.
  • worked, disabled cloudflare ....
  • Great. :)  I'll mark this as resolved and close this then.
This discussion has been closed.