Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Osticket 1.10 and GMail email with SSL on SMTP

Good morning,

So we have been looking at the forum and all sorts of resolutions for this over the last week. IMAP works and auths no worries however SMTP not working.

I have tried everything. ssl://smtp.gmail.com on port 465 and 587. The error we get is the following.

Failed to connect to ssl://smtp.gmail.com:465
[SMTP: Failed to connect socket: stream_socket_client(): unable to
connect to ssl://smtp.gmail.com:465 (Unknown error) (code: -1, response:
)]


We have tried with auth on and off. have even tried tls://smtp.gmail.com and both 465 and 587 same basic error.

I have made sure the less secure connection option in gmail is enabled. truly this feature should be a HIGH priority for OsTicket to resolve. I also run a wordpress site with a simple plugin to allow emails to be sent when anything happens. its using a gmail account took 2min to configure without a hitch. Why should this be so hard if your POP and IMAP options already have simple selections.

Thank you for you time.
Regards,
Mynty.

Comments

  • Firewall issue blocking port? Would be best if you provided more details about your environment.
  • firewall on the linux VM is enabled or allow pass through of the ports. but will investigate the NAT.
  • Which linux distro are you using? 
  • edited May 11
    No one here can help you.  Want to know why?  Because you have provided us with no real details about your issue.  Such as osTicket version, server environment and version details.  Are you actually using gmail or are you using GSuite?

    Please help us to help you by reading and following the posting guidelines located in this thread: Please read before requesting assistance.  The more information you give us the better we will be able to assist you. Thank you.

    edit: movnig thread to appropriate section of forums.
  • Good afternoon,

    If you read the title of my post it contains the relevant information regarding what version i am running. 1.10 your latest stable version.

    the issue is in red part of my post. what is GSuite? using plain old gmail like you would setup for a person. I have used gmail with way for my wordpress site and works just fine.

    Running Ubuntu 16.04
    Your application was installed using AMPPS
    Server is running on a VMware 6.0.
    everything else works here. but the error im getting in red.

    Thanking you.
Sign In or Register to comment.