Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

WSOD on Install with PHP Fatal Error

FYI, I'm not a novice to osTicket. I've been using it for years. 

Setup a new install with v1.10 on a CentOS 6 server running php 5.3.3 and a vanilla LAMP stack. 

I have the WSOD, can't get to the setup, but the domain is working because a .txt file placed via FTP can be brought up in browser via URL with no issue so I know it's not a domain issue. 

Domain: support.vreia.org

Error logs are showing the following:






PHP Fatal error:  Only variables can be passed by reference in /var/www/html/support.vreia.org/include/class.plugin.php on line 555

Here's line 555 in class.plugin.php:

image



Any idea how to fix this so I can complete the install?

Tagged:

Comments

  • Upgrade your PHP to 5.6

    1.10 does not work well with versions of PHP older than 5.6
  • @blueyeguy

    Thank you, that fixed it!

    It's now throwing the following error which I'll put in a new post:

    Warning: Declaration of AssignmentForm::render($options) should be compatible with Form::render($staff = true, $title = false, $options = Array) in /var/www/html/support.vreia.org/include/class.forms.php on line 4150

    Warning: Declaration of TransferForm::render($options) should be compatible with Form::render($staff = true, $title = false, $options = Array) in /var/www/html/support.vreia.org/include/class.forms.php on line 4270
Sign In or Register to comment.