Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Warning: Declaration of AssignmentForm

New install of osTicket v1.10 on CentOS 6 with PHP 7.0.18 with Zend OPcache v7.0.18

Throwing the following two errors across all pages at the top:

Warning: Declaration of AssignmentForm::render($options) should be compatible with Form::render($staff = true, $title = false, $options = Array) in /var/www/html/support.vreia.org/include/class.forms.php on line 4150

Warning: Declaration of TransferForm::render($options) should be compatible with Form::render($staff = true, $title = false, $options = Array) in /var/www/html/support.vreia.org/include/class.forms.php on line 4270


Tagged:

Comments

  • This is going to sound a little repetitive, I would downgrade to PHP 5.6 (the version I suggested in your other post).

    1.10 has reported issues with pre 5.6 PHP, but there are also some issues reported with 7.x

    I have seen it suggested that if you have to run PHP 7.0 that you upgrade to PHP 7.0 while running 1.9.15 and then upgrade to 1.10, and I would not try to run PHP 7.1
  • Haha, first you tell me to upgrade PHP. Now you tell me to downgrade PHP. ;-)

    I upgraded to PHP 7 because one of our Wordress themes requires it. Didn't realize it was going to cause another issue. 
Sign In or Register to comment.