Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

[resolved] Thread is Blank When Adding Custom Form Fields

Hi all,

I'm running this:
osTicket Versionv1.10 (901e5ea) —  Up to date
Web Server SoftwareApache/2.4.25 (Debian)
MySQL Version10.1.22
PHP Version7.0.16-3

All of a sudden, when I add custom form fields (such as choices for business areas affected and number of users affected) once the user submits a ticket, they're unable to view the thread. I have enabled the error messages in osTicket so I'm confronted with this message:

Fatal error: Uncaught Error: Call to a member function getField() on null in /var/www/html/osticket/include/client/view.inc.php:125 Stack trace: #0 /var/www/html/osticket/tickets.php(141): include() #1 {main} thrown in /var/www/html/osticket/include/client/view.inc.php on line 125

When viewing the file it references, I couldn't see anything that looked like it'd be causing the issue:

<?php foreach ($sections as $i=>$answers) {
if (in_array($answer->getField()->get('name'), array('name', 'email', 'subject')))
continue;
elseif ($answer->getField()->get('private'))
continue;
?>

Attached is a screenshot.
Any ideas? Cheers.

Comments

  • Apologies, here's the screenshot.



    image
    Untitled.png
    1920 x 1050 - 43K
  • You appear to have installed a 3rd party theme mod.  If you are using a theme mod I would recommend reinstalling from the download archive and see if you have the same problem.  If you do not then you know that it is something that the theme mod has done that breaks things.  
  • Gotcha, worked minus theme.
    Contacted theme author and he provided me with an updated version that fixed the issue.
    Cheers!
  • Great! Glad to hear it.  I will close this thread and mark it resolved.  Please feel free to start a new thread if you encounter any other issues.
This discussion has been closed.