Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Email Piping Issues

Hi all,

With regards to email piping; how do I actually set this up?
I have osTicket installed on a virtual machine separate from my mail server and cPanel.

I have followed the documentation located here, but how does cPanel know which server my script is located on?

Meanwhile, on my osTicket admin installation, I keep receiving the error messages:
[CLOSED] IMAP connection broken (server response)
Invalid login. Check IMAP settings
When I attempt to fill out the IMAP details. I'm using the exact same details as the SMTP (which works fine). I've used ports 143, 995, 25, 993 and 443. (IMAP is enabled for the email address I wish to use)

I've set up a cron job on the osTicket server and given it the API key I've set up in the Admin Panel (I assume the IP for the key is for the mail server? Either way there are two API keys, one set up with the IP of the osTicket server and one with the IP of the mail server) - no joy.

Does anyone have a step-by-step guide of how to set this up? 

I'm using: 
osTicket Versionv1.10 (901e5ea) —  Up to date
Web Server SoftwareApache/2.4.25 (Debian)
MySQL Version10.1.22
PHP Version7.0.16-3
Cheers

Comments

  • Just taken a look at the firewall settings on my mail server and they allow these ports also.
  • Q: how do I actually set this up?
    A: I do not use email piping because I'm on Exchange.  You would want to read the instructions (that you already linked) to do it.

    Q: I have followed the documentation located here, but how does cPanel know which server my script is located on?
    A: CPanel is a webinterface that runs on your webserver... where the program is located.  And would need to have a mailserver on your webserver also.  You should look at the Remote Piping section of the link you mentioned if the mailserver is not on the same server.

    Regarding IMAP:
    Please provide a screen shot of your email settings.
    What mail server software does your mailserver run?
    Are you prefixing the mail server host name with ssl:\\?
    Can you downgrade PHP to 5.6?
    • Attached screenshot (tried all of the variations of port number, with varying error messages)
    1. ssl:\\ prefix provides error message: Can't open mailbox {ssl:\\outlook.office365.com:143/imap/novalidate-cert}INBOX: invalid remote specification
    2. no prefix provides the message: IMAP Authentication cancelled
    3. using the FQDN for the mail server provides this: [CLOSED] IMAP connection broken (server response)
    • Exchange
    • Yes
    • What are the other ramifications for doing this?

    Cheers
    Untitled.png
    943 x 259 - 18K
  • Your image is using a port that is not SSL, and a protocol that is not SSL.
    Yet on your hostname you are using SSL.

    Try:
    Change Port Number to: 993
    Change Mail Box Protocol to: IMAP + SSL

  • Setting the port to 993, with the ssl:\\ prefix and mail box protocol as IMAP + SSL results in this:
    Can't open mailbox {ssl:\\outlook.office365.com:993/imap/ssl/novalidate-cert}INBOX: invalid remote specification
    Everything I try also results in Invalid Login: Check IMAP Settings at the top of the screen also.I know the login is correct because SMTP works.Cheers
  • IMAP and POP3 both show up as Enabled on the mailbox I'm connecting to and the account I'm using to connect to it also.
    Interestingly enough, after adding an address, port and protocol to the entry for ExternalConnectionSettings in IMAP settings on the exchange server, and then removing the ssl:\\ prefix, I get this:

    TLS/SSL failure for outlook.office365.com: SSL negotiation failed

  • Also, not sure if this makes a difference or not, but this is to fetch emails from a shared mailbox.
  • That's your problem.  You cannot use a shared inbox.  It has to be a dedicated inbox.

    Someone else found a way to make it work that isn't advertised by Microsoft, that you can probably find on the forums if you search hard enough though.
  • Just tried adding another email which is not a shared inbox and I'm still getting the issues
  • Did you give the account IMAP access?  

    We use Microsoft o365 Echange here and it works so I can only conclude that it is your setup (PHP version and extensions, your o365 Exchange confiuration, or a fire wall on your webserver).
  • Yes, the only thing that remains is the php version or extensions.

    Firewall is allow all on osTicket and allow relevant ports on the mail server.
    IMAP is enabled.
Sign In or Register to comment.