Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

[resolved] osTicket v1.10 subject is blank

Hi,

I am using osTicket v1.10 on top of Apache and mysql. Below are my apache and mysql versions.

Apache version: Apache/2.4.6 -CentOS 7
Mysql  Ver 15.1 Distrib 5.5.52-MariaDB   

What my issue is , I can not see the subjects of tickets from the dashboard. I have attached the screenshot here with. This is how I see the subjects, as you can see its empty.

I am aware that I have to specify the subject from the Help Topic > Issue Summary as I don't have any other place to select the subject when creating tickets. But even after I chose the Issue Summary it doesn't appear on the Subject field as in the attachment. Therefore I would like to know whether this is the normal behavior or is there any way of adding the subject of a ticket.

My major requirement is , when an user addresses an issue via the e-mail I need to set the subject of e-mail as the subject of the auto creating ticket.Simply I need to match the e-mail subject with the ticket subject. But currently auto create ticket subject is empty. Even If I create a ticket manually the subject of the ticket is empty. I went through this https://github.com/osTicket/osTicket/issues/3224 but it didn't help me to fulfill my requirement as it has the guidance to set a default subject.

Could you please assist me to solve this problem?

Please note that there are no specific errors in the apache error so I din't attach the error log.

Thank you,
Best Regards,
Thinusha

Comments

  • I can't see your screenshot (maybe try attaching again?), the only time I've seen this happen was to someone who set the field to be a "Choice", instead of a Textbox. Have you played with the fields? 
  • Hi Grizly,

    Thank you for the reply. Here with I am attaching my screen shot again.


    osticket_subject_empty.png
    958 x 387 - 74K
  • Hi Grizly,

    I didn't touch any field settings & this is a fresh installation except for fewer customization. Its possible me to see the subject If I open an ticket but dash board doesn't show me the subject. Here with I have attached another screen shot which shows the subject inside the ticket.
    Osticket_inside_a_ticket.png
    958 x 579 - 84K
  • Are you using the Queues Beta? Because I don't have the department on my 1.10 ticket list.

    The "except for few customisations" bit makes me think you've changed something that might need more work, what did you change for that? Maybe you missed something? Chuck it in a gist or similar.
  • I notice that you have not mentioned what version of PHP you are running.

    And have you checked the PHP error log?
  • Hi,

    I have no idea about "Queues". Is it a plugin? If it is, I have not installed any plugins. What I have downloaded is the latest stable release & my setup file's sha256sum value (68ff411693802e154426d9ec9b2365ff524aad5f6e52ad9422f073ae48e3a46d) equals to what is in the site.

    Here is the version info as well as I did attach the apache error log here with.

    osTicket Version     v1.10 (901e5ea) — Up to date
    Web Server Software     Apache/2.4.6 (CentOS) OpenSSL/1.0.1e-fips PHP/5.4.16
    MySQL Version     5.5.52
    PHP Version     5.4.16

    error_log.txt
    18K
  • 1.10 is not very friendly with PHP older than 5.6 and newer than 7.0, I would try upgrading the PHP to 5.6 and see what happens.


  • Hi blueyeguy,

    As per your suggestion I upgraded php5.4 to php5.6. but still I am having the same issue. Here is my new php version.

    Server Information
    osTicket Versionv1.10 (901e5ea) —  Up to date
    Web Server SoftwareApache/2.4.6 (CentOS) OpenSSL/1.0.1e-fips PHP/5.6.31
    MySQL Version5.5.52
    PHP Version5.6.31

    Any help will be highly appreciated.


  • Please go to:
    Admin panel -> Manage -> Forms -> Ticket Details
    Locate "Issue Summary"
    What does it say under Visibility?
  • Hi ntozier,

    It says "Required". I have attached a full screen shot for you reference. Thank you 
    os-ticket_issue_summary_visility.png
    1049 x 780 - 70K
  • Chance "Issue Summary" to Short Answer.
  • Hi ntozier,

    I can see now some tickets showing the subjects but some not.
  • Is it possible the ones that you cannot see s imply do not have subjects? (ie were created via email without a subject)
  • edited July 19
    "I didn't touch any field settings"

    Screenshot of field settings with myriad changes.. including changing the summary from text to choice
  • Hi ntozier,

    Actually they are not e-mails without subjects. They do have a subject when I open the ticket.But I don't mind not showing them as they are old tickets. The good news is when I send a  new test e-mail now it picks the subject  & shows nicely in the dash board. That is what I was looking after. 

    But I would like to address you that I didn't change the issue summary to "Choices" as far as I am aware. If it is something coming as a default option its worth to set as "Short Answer" as it will save lot of  of hours of the rest.

    Anyway Thank you very much for your support.It helped me lot.
  • If the ticket was created while that setting was set to choice, the data is basically gone, it's saved differently in the database.

    Also, the original is a textbox.
  • The default (ship) setting is "Short Answer" so someone changed it.

    There is a chance that the others [Issue Summary] will show up in time (the system caches information).
  • Hi Grizly,

    I can manage with the loss data that is fine. Did u mean "checkbox" ? "textbox" is not available under options.
    options.png
    1040 x 368 - 36K
  • @thinusha, I don't even see Issue Subject listed in your for fields in your screen shot.

  • image
    IssueSubject.JPG
    719 x 432 - 68K
  • Hi blueyeguy ,

    Are we on the same version?
  • Ah, I see you changed the Label for it from Subject to Summary, 

    If you change that back?

  • edited July 19
    Yes I am 1.10

    Server Information
    osTicket Version v1.10 (901e5ea) —  Up to date
    Web Server Software Microsoft-IIS/7.5
    MySQL Version 5.7.17
    PHP Version 5.6.24


  • Its strange. I don't have those fields. May be osticket has released multiple versions with the same release number with tiny changes. 
  • "I didn't touch any field settings & this is a fresh installation except for fewer customization."

    Did you make any customization modifications to the source files?

    osTicket has one official release, did you get yours from http://osticket.com/download
  • I meant fewer customization as "Branding , E-mail fetching , e-mail template" those stuff. I din't touch the source or I am not a developer either.  I downloaded from the same link as well. 
  • "Its strange. I don't have those fields. "

    Yes you do, you have have those same fields, plus several other custom fields that I do not, but your Issue Subject field is labeled Issue Summary, and if you didn't change that, then I don't know why it would be different.

  • Hi Blueyeguy,

    My colleague was also working with this & I am not sure whether he did those changes or not but his initial answer was no. Anyhow I will confirm further if he has done any changes or not to the fields. Thank you all for the support. 

  • Hi Guys,

    You can close this ticket as my colleague confirmed that he has done changes to fields. Sorry for the misguidance that I made initially by saying that "I didn't make changes to fields" . It has happened actually without my awareness. Anyway thank you very much all for solving this issue.
  • No problem. Glad we were able to track down the problem and you got it solved. I will mark this resolved.
This discussion has been closed.