Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Problem configuring GMAIL IMAP

Hi, after configuring and saving gmail with imap, i've got this error on imap:

Unable to create TCP socket: Address family not supported by protocol

Disabling imap, with smtp active, the system work only for send email (attachment 1).
I tried with no-gmail account and I've got same error 

I read all the old ticket, and I've choose the drastic solution to change provider and server, but I've the opposite situation: imap works and smtp no with a different error (attachment 2):

Failed to connect to ssl:// [SMTP: Failed to connect socket: Network is unreachable (code: -1, response: )]

I tried with no-gmail account and I've got same error 

How it's possible? Please, help me to solve!


  • Please help us to help you by reading and following the posting guidelines located in this thread: Please read before requesting assistance.  The more information you give us the better we will be able to assist you. Thank you.

    No osTicket version.
    No server environment details.

    My guesses are:
    you have not enabled the account at google to allow imap.
    if Linux that you have not installed php-imap
    if windows you have not enabled the imap extension.
  • Sorry,

    the osticket version is 1.10, installed both on linux server with php 5.6

    Regarding your tips:
    - imap and pop are enabled on gmail
    - imap is installed, you can check the php.ini files

    Here the php.ini file for first case:
    Here the php.ini file for second case:
  • Email settings?
    Firewall?  SELinux?
    Can you telnet from the server to the server/port?
    Can you ping the IP of the server []? (If it works with IP then its likely a DNS issue)
  • I tried to telnet from my server to different SMTP, port 465 is open and there aren't firewall rules.

    # telnet 465
    Connected to

  • Email settings?
    Did you create a rule in Exchange to allow the connection?
    Does the user have permission to send/collect emails?
Sign In or Register to comment.