Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

BUG: Custom Logo, inline images, attached images are generating errors and will not be displayed

Hi there,

we have a absolut clean unmodified installation of latest osTicket 1.10., uploaded custom logos and inline images are stored in the database (table "file") but will not be displayed. The actual system info:

osTicket Version     v1.10 (901e5ea)
Web Server Software     Apache
MySQL Version     5.7.17
PHP Version     5.5.38

We know that images stored are displayed via file.php and the stored values in the database:

A. That is the call of an uploaded custom logo:

OSTICKET/file.php?key=nh8geiwca5magzzc9kxepjq30pq9as7y&expires=1500854400&signature=fbc545b10c901826899e7e7e51e7f16ada69f4e2

B. This is the call of an attached image to a ticket:

OSTICKET/file.php?key=zw-hec9w7u18suhopwof3mesviqq80ue&expires=1500854400&signature=bd07e7794ca52756626a9179aa631cb0167becd3

C. This is the call of an inline image in a ticket:

OSTICKET/file.php?key=wjltx517vjctvta7g1fs1gqjm4nwcmq8&expires=1500854400&signature=6f1bbf663e607eba590dd937b61fb068ff80fbca

-> all images are stored in the database and the entries are looking correct
-> online call generates the error: could not be displayed because the image contains errors
-> download jpg and open it in Photoshop generates the error: unexpected end of file (eof)
-> download png and open it in Photoshop generates the error: could not be interpreted
-> please could you give us more details to "expires" > it's only checking the actual session, or?

To get closer to that problem, we did the following

1. We switched PHP version: 5.5 latest cgi, 5.5 latest fpm, 5.6 latest cgi, 5.6 latest fpm, 7.0 latest cgi, 7.0 latest fpm  > has no effect, error stays
2. We tried different image types e.g. png, jpg > has no effect, error stays
3. We tried attachments to filesystem > has no effect, error stays
4. We tried downloading attached files > has no effect, error stays
5. We tried other attachment types e.g. pdf > are working correct, no file damage
6. We opened the stored blobs in file_chunk directly in Photoshop > are working correct, images are displayed

Any ideas? Best regards, Jürgen
Tagged:
Sign In or Register to comment.