Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Tickets fetching issue

Hi Team,

In our server osticket is not fetching the tickets automatically , every time we need to logout and login to get the tickets. and if i refresh multiple times then multiple tickets creating for a single email.

I setup the cron job also to fetch the tickets .

*/1 * * * * root /usr/bin/php5 -f /var/www/html/osticket/api/cron.php

Still its not working fine for me.


Server Information
osTicket Version    v1.9.12 (19292ad) 
Web Server Software    Apache/2.4.7 (Ubuntu)
MySQL Version    5.5.57
PHP Version    5.5.9-1ubuntu4.22
OS- Ubuntu 14.04 (Server os)

Please help me with this

Regards
Rajendra.

Comments

  • This: "every time we need to logout and login to get the tickets."
    Means that you have Admin panel -> Emails -> Settings set to "Fetch on Auto-cron".  This setting is recommended as being set to off.  While you are at the page however you will wnt to make sure the Email Fetching is set to Enable.

    Then go to your email address at:
    Admin panel -> Emails -> Email -> your email that your collecting for.
    And provide us with the settings.

    You also might want to check your PHP logs for error messages.
  • Previously Admin panel -> Emails -> Settings set to "Fetch on Auto-cron". was set to on. now i made it to off. and the email fetching is Enable .

    Please find the below attachments . If you can provide your mail id i can send you the php logs as well.


    imageimageimage
    ost.JPG
    955 x 632 - 90K
    ost2.JPG
    1287 x 433 - 274K
    ost3.JPG
    587 x 198 - 38K
  • Okay all the basic settings look good.
    my email is neil at osticket com for the PHP error logs.
  • oh I had a thought... isn't Ubuntu's Apache user actually www-data?  So shouldn't your cron use www-data and not root?
  • So you want me to USE
    this
    */1 * * * * www.data /usr/bin/php5 -f /var/www/html/osticket/api/cron.php

    instead of

    */1 * * * * root /usr/bin/php5 -f /var/www/html/osticket/api/cron.php
    for cron job

    Right?
  • If i uncheck the fetch auto-corn , then the tickets are not replicating in osticket, even though i refreshed and logout and login.

    once i check the fetch auto-corn , again its replicating.  But the problem is every time i need to refresh or logout and login to osticket. and i have made the setting of auto refresh to 1 minute also.

    Please help me to fix this issue.
  • What happens when cron runs? Can you run that command manually and capture the output?
Sign In or Register to comment.