Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Best course of action when php 7 is the only option

I don't have the option to use anything other than PHP 7. (7.0.22) or higher.
What would be my best option at this time?

I gave 1.10 a try on my dev machine, but I ran into multiple (making the software non-usable) issues, and they all appear to correlate to known issues with PHP 7. 

I looked into the option to use an earlier version, but it's not available, and in the intended environment, compilation isn't an option.  So just asking if there's any option, including if perhaps 1.9.15 works better with PHP 7 or anything.

Comments

  • I was told by the devs that installing under php5.6 and then upgrading to php7 is the way to go if you want to run php7.  Versions pre 1.10 did not support php7 at all so that wouldn't be an option.  Installing under php7 causes some issues for some people.  What issue are you facing running/installing under 7.0?
  • Side note someone answered your other thread.  He seems to have gotten through installing under php7

    http://osticket.com/forum/discussion/91058/ajax-form-assign-ticket-doesnt-work-because-of-failed-template-info#latest
  • I don't have another thread?


    Also, since there's zero option for php 5, installing under it and upgrading isn't an option.

    As far as the issue's I've hit, I had the one fixed by the changes in this pull request: https://github.com/osTicket/osTicket/pull/3349/files

    and then the one with blank Ajax that I commented on saying I had the same issue you linked.

    Those are the two I ran into.  I manually applied that commit which fixed that issue, but I was unable to find any solution for the Ajax one when not able to do the initial install with php5. 

    The reply in the thread you linked mentioned fixing form visability, is that by any chance referring to the ajax issue?  If so I can give it another try over the weekend on my dev server, but I'm not sure I could use this on production like this.


  • edited September 2017
    Your right its Tomatoes thread, you just commented on it.
    http://osticket.com/forum/discussion/91058/ajax-form-assign-ticket-doesnt-work-because-of-failed-template-info#latest

    No.  Admin panel -> Manage -> Forms -> check all the forms by going into them and clicking on config and making sure that the display settings are right.
  • Ok, well I'll give those a shot over the weekend on my dev machine.  If it seems stable, I'll push the option for production.
  • good luck, and please let us know how you make out on this!
  • You should be able to get it running under php7 following the brief post and links in my comment http://osticket.com/forum/discussion/comment/117346/#Comment_117346

    Let us know if you were able to fix it.
  • Tomatoe, I'm taking a look right now, how does the file editing fix you're mentioning compare to the one in this pull request: https://github.com/osTicket/osTicket/pull/3349
  • Update:

    I haven't had a chance to really test yet, but I have it installed, I fixed up the forms (not sure if I matched what they should have been, but they do show up now), and I used the fix from the github pull request I linked.

    I'll try to test over the course of this week.  Rather than my dev environment, I installed it on my home server (same config) so I can try and get some live testing done.  I'm going to make my family use it ;)
  • An update:

    After correcting the forms with the incorrect permissions and applying the changes present in this pull request
    https://github.com/osTicket/osTicket/pull/3349

    I have not run into issues on my dev system.  I deployed it for use on my personal server with family for very light use and haven't run into anything, though I'm not sure how vigorously it was used. (Mainly was just for them to submit new device access requests, since I use static ARP)
Sign In or Register to comment.