Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Cron not creating ticket from e-mail

Hi there,

I am having an issue with creating a ticket from e-mail.
Everything in the e-mail config seems configured properly but when I run the cron file from CLI I get the following error:

PHP Fatal error:  Uncaught InvalidArgumentException: List indices should be integers in /var/www/html/osticket/include/class.util.php:149
Stack trace:
#0 /var/www/html/osticket/include/class.forms.php(81): ListObject->offsetExists('name')
#1 /var/www/html/osticket/include/class.ticket.php(3004): Form->getField('name')
#2 /var/www/html/osticket/include/class.ticket.php(3182): Ticket::filterTicketData('Email', Array, Array, NULL)
#3 /var/www/html/osticket/include/class.mailfetch.php(796): Ticket::create(Array, Array, 'Email')
#4 /var/www/html/osticket/include/class.mailfetch.php(845): MailFetcher->createTicket(3)
#5 /var/www/html/osticket/include/class.mailfetch.php(925): MailFetcher->fetchEmails()
#6 /var/www/html/osticket/include/class.cron.php(25): MailFetcher::run()
#7 /var/www/html/osticket/include/class.cron.php(100): Cron::MailFetcher()
#8 /var/www/html/osticket/include/api.cron.php(19): Cron::run()
#9 /var/www/html/osticket/include/api.cron.php(40): CronApiController->run()
#10 /var/www/html/osticket/api/cron.php(23): Lo in /var/www/html/osticket/include/class.util.php on line 149

I have searched through the forums and the Github issues and cannot find any information other than older information around language packs. 
I don't have any language packs installed besides the default en_US.

Below is my environment information:
osTicket 1.10
PHP 7.0.22
Ubuntu16.04 LTS
Apache/2.4.18
MySQL 5.7.19

Any help would be appreciated.

Thanks,
Oliver
Tagged:

Comments

  • Weird, have you edited any of the forms? Like, one with a field called Name?
  • It looks like somebody did update the contact information form and added fields while removing the 'Name' field and customising others.
    I have re-added the name field.
    I am not sure if this is relevant, but my change seems to have completely removed the table 'ost_user__cdata' table from the database - Hopefully this doesn't cause other issues.

    The e-mail ticket creation is working now 
    Thanks for pointing me in the right direction.


  • No worries mate, it was in the stack trace you posted. :-)
  • The ost_user__cdata table is a temporary table the system should regenerate it when it needs to.
  • I have tested extensively and all is woking well.
    Thankagain Grizly for the help and thanks ntozier for the info to put my mind at ease.
Sign In or Register to comment.