Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Incorrect Time Format - when using 24hrs schedule (Netherlands)

Hi,

We are evaluating osTicket v1.10.1 on a Synology NAS for some weeks now and are pleasantly suprised by the product sofar.
Nonetheless we are struggling with the Date and Time format settings. Setting other than the standard settings show wrong and incorrect timestamps.

osTicket Version: v1.10.1 (9ae093d) —  Up to date
Web Server Software:Apache/2.2.34 (Unix) mod_fastcgi/mod_fastcgi-SNAP-0910052141
MySQL Version:10.0.31
PHP Version:5.6.31

Our problem:
When setting it to default local settings: the system show tickets with correct timestamps but in 12hrs AM/PM format. When using any other different setting towards our own region, which is 24hrs format (Europe/Netherlands), it does show incorrect time format because still showing AM/MP signs, even when using Advanced format, and wrong creation date/timestamps,always saying it has been created 10 minutes past a whole hour.See picture attached

As you can understand correct timestamps are crucial for a ticket system. So maybe someone has a clue for this problem.

Best regards
Ashley Pietersen

Comments

  • Make sure that your server time, php datetime, mysql datetime, and osTicket date time are all the same.
  • Thanks,

    Synology NAS-time has been checked, I would expect that all apps derive date/time from NAS.

    How to check/set php and mysql time seperately? - 

    Does that explain the reason why Create timestamp  always say something like:15:10, 13:10 16:10 etc? 

    I noticed that my attached screenshot was lost in my post, I will try it again

    BR
    Ashley Pietersen
    osTicket-4.PNG
    400 x 351 - 25K
  • Hi ntozier,

    not sure how to check date and time in php and mysql. This I the only things I can do for now, see attachment 
    osTicket-5.PNG
    731 x 542 - 47K
  • it has trouble to attach file, again...image
    osTicket-5.PNG
    731 x 542 - 47K
  • The datetime is set in your php.ini.  I'd check there.

    Can you rin a SQL query directly?

    try this: SELECT @@global.time_zone, @@session.time_zone;
  • Hi ntozier,

    Thanks.

    I will try, just installed phpMyAdmin on the Synology, and I saw I could query the database. I think..
    will keep you posted here...





  • this is my result starting a query within phpMyAdmin. I am not sure I did it rightm it looks if I doing something wrong.see attachment
    osticket-results-query-1.PNG
    623 x 574 - 32K
  • image
    osticket-results-query-1.PNG
    623 x 574 - 32K
  • select * from ost_config, results:image
    osticket-results-query-2.PNG
    864 x 517 - 69K
  • edited October 25
    @apietersen I'm a bit confused here so please bear with me while I try to get this straight. So, you're saying that since you don't want the 12 hr time format you used Advanced Date & Time settings to set your own format, but upon doing so the actual time is off by 10 minutes from the hour?
  • Yes I think that is correct. Only the defaukt settings, which is 12hrs AM/PM, produce correct timestamp. Any other setting: such as: Europe/Amsterdam , local 24hrs setting, and advanced custome format produce incorrect format. Always with a +10min offset from an hour , which is defintely not the real time it supposed to be. If you want I can give you access to our system, if that helps...please let me know.

    image
    osTicket-6.PNG
    418 x 412 - 34K
  • @apietersen 

    No remote access is needed. Send me a screenshot of where you set all these: "Europe/Amsterdam , local 24hrs setting, and advanced custome format"
  • these are the settings I use now:
    osTicket-7.PNG
    881 x 427 - 33K
  • image
    osTicket-7.PNG
    881 x 427 - 33K
  • Okay so your issue has a VERY simple resolution....use the correct format lol
    You have 'HH:MM' which 'HH' is the hour in 24 hr notation and 'MM' is the month. That's why you're getting `:10` on all the times, because it's October, the 10th month. So update all the 'HH:MM' to 'HH:mm'. After that save your changes, re-test, and get back to me. Cheers.
  • HI Kevin, just tested it and you are right :-)   it is working and showing datetime format OK now.
    For your information the "local default, 24hrs" keeps showing 12 AM/PM format. Do not understand, but that is not relevant anymore, I will use the Advanced setting. Thanks a lot for your support.

    Best regards
    Ashley Pietersen
Sign In or Register to comment.