Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

[resolved] osticket 1.10 pop up blank

New install of 1.10 Everytime I hover over "?" the help / tip pop up block comes up blank and when i trying to delete tickets same blank block appears.
 
osTicket Versionv1.10
Web Server Softwarenginx\1.10.3
MySQL Version14.4\distrib 5.7.20
PHP Version7.0 

Comments

  • edited November 7
    nginx config
    server {
    listen 80;
    server_name xxxxxx;

    root /var/www/html/osticket/upload/;

    access_log /var/log/nginx/access.log;
    error_log /var/log/nginx/error.log;

    index index.php;
    client_max_body_size 2000M;
    client_body_buffer_size 100M;
    client_header_buffer_size 10M;
    large_client_header_buffers 2 10M;
    client_body_timeout 12;
    client_header_timeout 12;
    keepalive_timeout 15;
    send_timeout 10;
    gzip on;
    gzip_comp_level 2;
    gzip_min_length 1000;
    gzip_proxied expired no-cache no-store private auth;
    gzip_types text/plain application/x-javascript text/xml text/css application/xml;

    set $path_info "";

    location ~ /include {
    deny all;
    return 403;
    }

    if ($request_uri ~ "^/api(/[^\?]+)") {
    set $path_info $1;
    }

    location ~ ^/api/(?:tickets|tasks).*$ {
    try_files $uri $uri/ /api/http.php?$query_string;
    }

    if ($request_uri ~ "^/scp/.*\.php(/[^\?]+)") {
    set $path_info $1;
    }

    location ~ ^/scp/ajax.php/.*$ {
    try_files $uri $uri/ /scp/ajax.php?$query_string;
    }

    location / {
    try_files $uri $uri/ index.php;
    }

    location ~ \.php$ {
    fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
    include fastcgi_params;
    include snippets/fastcgi-php.conf;
    fastcgi_pass unix:/run/php/php7.0-fpm.sock;
    fastcgi_param PATH_INFO $path_info;
    }
    }
  • This post slightly contradicts itself.

    You say new install of 1.97 (which I presume you mean 1.9.7 and have no idea why you would install such an old version).  You say later you are running 1,10.  This I can work with.  But now I have no idea what you mean by "new install of 1.97".

    As far as the ?'s and blank pop ups this is your server failing AJAX requests. nginx is not a support webserver for osTicket.  It will not work with out configuration changes.  I would highly recommend that you head over to github.com/osTicket/ and read and follow the numerous nginx issue reports there.
  • Sorry version is 1.10 stable
  • Well changining my webserver to apache2 fixed this problem
This discussion has been closed.