Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Slow Performance when saving tickets. v1.9.12

Hello everyone,

I am having the following issue when creating a new ticket or updating an existing one It takes a long time for the system to be updated.

Currently I am running osTicket v1.9.12
  • PHP version: 5.6.30
Any suggestions?


Tagged:

Comments

  • Maybe you disable this setting to see if it has an impact on this issue:
    ->Admin Panel->Settings->Email->uncheck "Verify email address domain" 
  • I have disable the option as you said. Will need some time to test it. Hopefully this solves my issue.

    Thank you for your answer.
  • When this was the reason for the behavior than you should check if you have dns or network problems. This option uses a dns check..
  • I have now closed couple of tickets and it takes 20 seconds to close one. 

    Other suggestions how I can improve the responsiveness of the system? 
  • edited November 20
    The only suggestions I have are:

    - Upgrade to a more current version.
    There was a lot of DB optimization stuff that happened between 1.9 and 1.10.  Much of how osTicket talked to the database changed.

    - throw more hardware at the problem
    You haven't told us what your hardware specs are for your server, or what your setup looks like so it's impossible to know what to recommend. Letting PHP or the webserver access more RAM might help.  

    - consolidate services as much as possible.
    have the web server one server, Mysql on another and mail on another and dns on another?  Or using a off network mail server?  Or using an off network MySQL server? bringing some or all of these services together can help performance.  Again you haven't told us what your setup looks like so it's impossible to know what to recommend.
Sign In or Register to comment.