Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

[resolved] System Log 'Log Date' missing

We're finally getting round to migrating from our current ticket system to OSTickets over the next few days, so just polishing our deployment before we go live.

one of the remaining issues is that the Log Date column is empty so makes it a bit hard to see when the last entry was.

we're running the following config
server 2008r2, IIS7
PHP7.0.21 x64 installed via WPI
OSTicket 1.10.1 (9ae093d)

php.ini file has been un-commented and amended to 'date.timezone = Europe/London'. IIS site was restarted.

still no Log Date information.
interestingly, OSTickets information tab still shows 'date.timezone

Europe/Dublin', but settings > system shows the correct Europe/London zone. red herring or something mis-configured there?

thanks for any help


  • Please help us to help you by reading and following the posting guidelines located in this thread: Please read before requesting assistance.  The more information you give us the better we will be able to assist you. Thank you.

    Well I can't claim to know every single column string or database column, but I'm not familiar with osTicket ever having a "Log Date" column.  

    And that string appears in the product exactly twice.  Once in /include/ajax.content.php and /include/staff/

    I really have no idea what it is that you are trying to ask us or relay to us.  Perhaps you can give us step by step instructions to get to what you are seeing, or provide us a screen shot demonstrating what you are talking about.
  • edited November 2017
    under the admin login is the dashboard > system log tab. screenshot as follows...

    we enabled the debug logging just so it triggers something at an event. The 'Cron Job' is set to run every 5mins via Windows Task Scheduler, as per the wiki.

    just for clarity, this is not related soly to the cron jobs, but also covers mailer, upgrader and DB error 'log titles'; all the same, no 'log date' column information. The 'ip address' column seems to have data in it when an action is performed by something other than the OSTicket host.  The 'upgrader' and 'db error' entries (not in screenshot) have been resolved so thats not an issue anymore - just issues upgrading from an older versions of PHP&OSTickets.

    what i'm asking is why is the 'Log Date' column empty? as far as i know, we have things setup correctly. Have i missed something when i configured the OSTicket installation, or is this a bug that needs resolving?

  • It shouldn't be empty.  I'm not using that same version of PHP at you (I'm running 5.6) but I have dates on my page.

    If you go to Admin panel -> Settings -> System what do you have under Date and Time Options?
  • looks like the 'TimeZone' option has updated from my original post. now showing europe/london (rather than europe/dublin

  • Looks like your date and time settings are not reading correctly? When set they should preview to the right, what it will look like, for all of the format settings:

  • edited November 2017
    The only real difference I see between yours and mine are the uppercase H for your hour formats, and for some reason you are also missing Default Locale option? Have you modified your source files, because I am also running 1.10.1 and I have the Default Locale setting.

  • Try changing Date and Time Format: to Locale Defaults.
  • edited November 2017
    pretty much fixed!
    used ntozier's suggestion about 'default locale' has got info in 'Log Date' column.

    changing back to 'advanced' date&time format makes the problem reoccur; log date column is empty.

    don't remember changing the source files from our original 1.9.x
    install in late 2015 when we first trailed OSTickets. from what i
    remember, it worked perfectly well out of the box so no reason to mod it
    (other than the official LDAP authentication plugin). Since I knew
    there were updates, i simply upgraded it to 1.10.1 via the
    install/upgrade options last week so not sure if the problem existed on
    1.9.x, or if it's related to 1.10 upgrade.
    It has made me a bit suspicious on what else we might find down the road, so since we don't
    currently have OSTickets deployed live, i might wipe it and start fresh.
  • edited November 2017
    If you look at the Date Time Format and the formatting options you have entered, it looks like there are a number of differences from what @blueyeguy has.  And 3 of the 4 don't show the sample format to the right of the box.  I think that perhaps there is a problem with the format strings or the three that do not have sample displays.  You could play with it to find out or simply leave the drop down on Default Local.  

    I've been running osTicket installations since 1.6ST and upgrading them (and cloning them and testing things) etc for quite a while now.  So I dont think that you have to do a fresh install.  But then you know whats best for you and your schedule. :)

    Should I close this thread?
  • well, I have tried a new instance of OSTicket; fresh 1.10.1 download, new SQL DB on the same server - same issue with the locale. only works properly when we use the 'default locale' 12h or 24h options. advanced still fails on the fresh install.

    anyway, the 'Default Locale 24h' option does what we want, so i'm happy that you close the thread as resolved for us.
This discussion has been closed.