Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Attachments wont open after update to 1.10.

PHP Version 5.6
OP-System: Linux
Plugin: Attachments on the filesystem

After updating to 1.10 the staff is not able to open attachments. i always get a Servererror 500 when i try to open a attachment. 

The Update ran without any error and open a ticket and the rest works well. 

I had a look at the filesystem and the permissions i have: Folders: 305 Files: 604

Please help! :)  


  • edited December 2017
    You should take a look in the error log of the web server.
  • edited December 2017
    wich error log? the accesslog said:

    217.91.xx.xx - - [13/Dec/2017:06:06:03 +0100] "GET /file.php?key=g6juyqmvnxzpijpaznx_dkzntv2fv-no&expires=1513209600&signature=xxxx  HTTP/1.1" 500 - "-" "Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/62.0.3202.94 Safari/537.36" "-"

    the php eroro i get: 

    Fatal error: Cannot make static method ThreadEntry::create() non static in class Message in /homepages/28/d232707697/htdocs/osticket/upload/class.thread.php on line 1261

    now i get a os ticket mail: 

    IOException: Unable to read resource content

    to open for reading

  • I'm not sure if this is a file permission problem. But you could easily try to adjust the permissions and see if this helps to determine this.

    I can also remember some people had problems when the filesystem plugin gets a bit confused (if you using it):
  • found the error. For some reason we had the "class.thread.php" two times in 2 directories.  

    i just deleted the one in the "upload"-folder. 

    attachments working again. 
Sign In or Register to comment.