Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

unable to create ticket for new added help topic

[SELECT A1.* FROM ost_help_topic A1 WHERE (A1.Id = 13 AND = 'Online Services / Patent Search') ORDER BY A1.topic ASC] Unknown column 'A1.Id' in 'where clause'

---- Backtrace ----
 #0 (root)/include/mysqli.php(204): osTicket->logDBError('DB Error #1054', '[SELECT A1.* FR...')
 #1 (root)/include/class.orm.php(3133): db_query('SELECT A1.* FRO...', true, true)
 #2 (root)/include/class.orm.php(3180): MySqlExecutor->execute()
 #3 (root)/include/class.orm.php(1771): MySqlExecutor->getArray()
 #4 (root)/include/class.orm.php(1815): ModelInstanceManager->{closure}()
 #5 (root)/include/class.orm.php(1794): CallbackSimpleIterator->next()
 #6 (root)/include/class.orm.php(1803): CallbackSimpleIterator->rewind()
 #7 (root)/include/class.orm.php(1463): CallbackSimpleIterator->valid()
 #8 (root)/include/class.orm.php(1480): CachedResultSet->fillTo(9223372036854775807)
 #9 (root)/include/class.orm.php(1149): CachedResultSet->asArray()
 #10 (root)/include/class.orm.php(1172): QuerySet->all()
 #11 (root)/include/class.orm.php(545): QuerySet->one()
 #12 (root)/include/ VerySimpleModel::lookup(Array)
 #13 (root)/include/class.api.php(278): TicketApiController->getRequestStructure('json', Array)
 #14 (root)/include/ ApiController->validate(Array, 'json', false)
 #15 (root)/include/class.api.php(227): TicketApiController->validate(Array, 'json', false)
 #16 (root)/include/ ApiController->getRequest('json')
 #17 [internal function]: TicketApiController->create('json')
 #18 (root)/include/class.dispatcher.php(145): call_user_func_array(Array, Array)
 #19 (root)/include/class.dispatcher.php(38): UrlMatcher->dispatch('/tickets.json', NULL)
 #20 (root)/api/http.php(35): Dispatcher->resolve('/tickets.json')
 #21 {main}


  • please help me out

  • You posted this in the 1.6 section of the forums, but this does not look like a 1.6 error.

    Please help us to help you by reading and following the posting guidelines located in this thread: Please read before requesting assistance.  The more information you give us the better we will be able to assist you. Thank you.

    Version of osTicket?
    Environment details?
    Steps to reproduce?

  • edited February 26
    Version of osTicket = 1.10.1
    Web Server Software = Apache/2.4.6 (CentOS) OpenSSL/1.0.2k-fips PHP/5.6.32
    MySQL Version = 5.6.35
    PHP Version = 5.6.32
  • Moving thread to proper section of the forum.

    I dont see anything wrong with your software versions.
    There is no 'id' field in that table.
    What is it that you are trying to do when you get that error?
  • I have added Online Services / Patent Search as a help topic when I try to create new ticket with  Online Services / Patent as a help topic i get above error. following is table structureimage
  • How did you add "Online Services / Patent Search" as a help topic?
  • By following below procedure

    Admin Panel -> Manage -> Help Topics -> Add New Help Topic
  • I cannot replicate your issue. I have gone to my production system.
    I have created two new help topics.
    Online Services 
    Online Services  / Patent Search

    I have also created a single Help Topic called:
    Online Services  / Patent Search

    I have tried to open a ticket with all three, and it works fine.  I can only presume that you some how modified the code, and/or are not using the version from  I recommend that you re-dowbload the distribution archive and re-upload it to your site.
  • I have not modified the source code and using the version from
Sign In or Register to comment.