Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Table 'osticket.ost_ticket__cdata' doesn't exist. SQL errors on fresh install.

Hi there,

I have a fresh install of osTicket:

osTicket Version v1.10-80-gc4669d7 (c4669d7)
Up to date
Web Server Software Apache/2.4.18 (Ubuntu)
MySQL Version 5.7.21
PHP Version 7.0.25-0ubuntu0.16.04.1
As soon as I click on the tickets panel in the agent section, I get three emails (the email errors are also visible in the logs-section).
One of them states:
(ticket_id)) DEFAULT CHARSET=utf8 AS SELECT entry.`object_id` as `ticket_id`, FROM ost_form_entry entry
JOIN ost_form_entry_values ans ON ans.entry_id =
JOIN ost_form_field field ON
WHERE entry.object_type='T' GROUP BY entry.object_id]

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'FROM ost_form_entry entry
JOIN ost_form_entry_values ans ON ans.entr' at line 2

The next two errors are also SQL errors. I skip them for now since I think this is a related issue.
The first part is a CREATE TABLE statement, but the second part is of a SELECT statement.

I also can't add tickets manually or do anything in the tickets section.

Any idea why my SQL statements are generated wrong?

Can someone please post the SQL to create the table 'ost_ticket__cdata' manually?

Kind regards




  • "v1.10-80-gc4669d7 (c4669d7)" 
    ^ This is not a version that I recognize and does not appear to be a valid version number.

    Did you download from ?

  • Hi ntozier,

    you're right: This is not the version from the download page but the latest github checkout.

    I downloaded and installed v1.10.1 from the page and ran into this error. On the github issues page I was asked if I have tried to reproduce this with the latest github version, which I did not at this point in time.
    I get the same issue with both versions.

    Can you provide me with the SQL statements for creating this missing table?
    If this solves my issue it would me take a step further.

    We can still evalualte why the table has not been created automatically or why I get these weird CREATE / SELECT mix in the SQL statement.

    Kind regards

  • I would probably assume that it is your mysql version.  Since I run 1.10.1 and do not get this error.  Also I've never seen this error before so if it was a wode spread thing then more people would be reporting it.  Maybe try a little older version of mySQL.
  • It looks to me that I'm suffering from this issue:

    I also see this errors in my apache2 error log:
    PHP Fatal error: Uncaught exception 'InvalidArgumentException' with message 'List indices should be integers'

    It looks like doing a fresh install with PHP 7.0 does not work, while upgrading an existing install would work, like other users reported.
    I'll check the suggestions and pull requests.
  • Ok thats weird: The issue occured due to the german translation package.
    I have uploaded the de.phar in the include/i18n folder and was able to select german as the system language.

    I did the installation again without uploading the additional language and finished the installer with english and now everything is fine.

    However, when I upload the language file now and select it under settings / system / primary language it is ignored. My installation is english now and I'm unable to switch to german.

    But this is another topic.
Sign In or Register to comment.