Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Do not send the Ticket Reply to the customer

we are using osticket to organize our internal tasks and it is not intendet to send the replies to the customers.
Is it possible to disable the notification to the customer or at least set the following setting (see attachmet) as default?

I disabled the notifications in the Admin settings but when we dont click the - do not send answer - button the customer still gets a notification mail for the ticket.

Thx and kind regards


  • One of the options in that drop down is something like do not send email.  You would choose that.

    You could also edit the code so that was the default.
  • ok where excactly do i edit the code?
    i just looked at it but didnt found the excact place to modify the settings.
    Kind regards
  • You're running a non-standard version or modified version.  If I did look and see where to do it, it wouldn't be right since your version differs from the download version.

    lines 556-576
  • ok great thank you 
    what excactly do i need to change here?
    i tried to change the lines but i cannot get the 2 option to be default selected.
    This section of the code does not differ from the original.

  • The line
    $emailReply = (!isset($info['emailreply']) || $info['emailreply']);
    is basically causing $emailReply to be true if $info['emailreply'] is not set, otherwise $emailReply is the value of $info['emailreply']. The behavior you want is instead for $emailReply to be false if $info['emailreply'] is not set, otherwise $emailReply should be the value of $info['emailreply']. To get this, you would do something like this:
    $emailReply = isset($info['emailreply']) && $info['emailreply'];
  • Wonderfull that worked great for me :)

    Thx for your help
Sign In or Register to comment.