Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

I can't save changes on Tickets and Task sections in control panel - settings.

I can't finish all the settings because the tickets ant task section doesn't works. I attach two the screen with the problem. Any suggestions?

Also I have this errors on php log

[11-May-2018 22:47:30 UTC] PHP Fatal error:  Uncaught InvalidArgumentException: List indices should be integers in C:\inetpub\wwwroot\AllianceSystems\include\class.util.php:149
Stack trace:
#0 C:\inetpub\wwwroot\AllianceSystems\include\class.forms.php(81): ListObject->offsetExists('message')
#1 C:\inetpub\wwwroot\AllianceSystems\include\staff\settings-tickets.inc.php(218): Form->getField('message')
#2 C:\inetpub\wwwroot\AllianceSystems\scp\settings.php(57): include_once('C:\\inetpub\\wwwr...')
#3 {main}
  thrown in C:\inetpub\wwwroot\AllianceSystems\include\class.util.php on line 149
[11-May-2018 22:48:16 UTC] PHP Warning:  Declaration of AssignmentForm::render($options) should be compatible with Form::render($staff = true, $title = false, $options = Array) in C:\inetpub\wwwroot\AllianceSystems\include\class.forms.php on line 4367
[11-May-2018 22:48:16 UTC] PHP Warning:  Declaration of TransferForm::render($options) should be compatible with Form::render($staff = true, $title = false, $options = Array) in C:\inetpub\wwwroot\AllianceSystems\include\class.forms.php on line 4487


Thanks

 

Comments

  • Please help us to help you by reading and following the posting guidelines located in this thread: Please read before requesting assistance. The more information you give us the better we will be able to assist you. Thank you. 
  • edited May 14
    Sorry, I attached a couple of images, but doesn't work, I am trying again.

    imageimage
    Settings.jpeg
    1092 x 809 - 254K
    tickets.jpeg
    1083 x 881 - 237K
  • edited May 14
    osTicket does not support PHP 7.1+ at this time.  Please downgrade to 5.6 or 7.0 and try again.
  • Thanks, Now i have php 7.0.27 but I still get the problem... additionally I found DB Error #1146 adn DB Error #1064 on the log system..

    Thanks
  • Did you restart IIS after changing PHP, and did you uninstall 7.1+?
  • edited May 15
    Yes, I restarted the ISS and the server and the problem still there.

    I attach a couple of images system configuration. Thanks

    image
    image
    image
    image
  • Could it be that you installed osticket with an additional language pack (=non en_us language pack)?
    osTicket 1.10 had a limitation with using this language packs during the installation process:

    Using the language packs after the installation is ok, but using it during the installation it causes errors.
    I'm not sure if this limitation is still there. But it sounds like that.

    Using the language packs after the installation is no problem but some of the content of osTicket will be not translated (for example the email templates, canned responses, etc.) because the translation will be created only during the install process. So you have to create/translate this content on your own via the gui when you can't use the language pack during the installation..
  • Hi mfelber, you're right, I'm reinstall without the language pack and now everything works fine.

    Thanks
  • Hi alextorres, I'm glad that I could help you.

    You're welcome
  • edited May 16
    /cheer @mfelber good catch!
  • @ntozier Thanks, as a daily user of additional language packs this type of issue comes easier to my focus.
Sign In or Register to comment.