Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Front Window in Blank when creating ticket or agent

Hi Guys,

I´ve been trying to find out why when creating an agent or ticket where it displays a front window to fill the info, it comes in blank.

Attached a screenshot when trying to create an agent.

I´ve have tried using, mozilla, chrome, explorer, safari and all same issue.

Hope someone can help.



  • Can you give me a screen shot showing us what you mean?
  • Attached screenshot
  • Please help us to help you by reading and following the posting guidelines located in this thread: Please read before requesting assistance.  The more information you give us the better we will be able to assist you. Thank you.

    I call that the white bar of death.  It means that your webserver is not properly handling AJAX calls.
  • Hi ntozier,

    Thanks for helping me up and for the useful info send however i am still having issues. 

    The log error i have is the following:

    ubuntu@ip-172-31-7-108:/var/log/nginx$ more error.log
    2018/06/08 00:12:10 [error] 2625#2625: *830 FastCGI sent in stderr: "PHP message: PHP Warning:  Declaration of AssignmentForm::render($options) should be compatible wit
    h Form::render($staff = true, $title = false, $options = Array) in /var/www/osticket/upload/include/class.forms.php on line 4367
    PHP message: PHP Warning:  Declaration of TransferForm::render($options) should be compatible with Form::render($staff = true, $title = false, $options = Array) in /var
    /www/osticket/upload/include/class.forms.php on line 4487" while reading response header from upstream,

    Attached also the version of the OSTicket installed.

    Hope you can help


  • You are running nginx.  osTicket does not support nginx and it will not run under it out of the box.  You can get it to run, but you will need to read through a bunch of the nginx threads over on github to get it to do so.  If you can it might be easier to switch to Apache2 which generally does run out of the box.
  • Hi Ntozier,

    Thanks.  Let me give it a try.  I´ll let you know the results.!
  • Any luck?
  • Hi Ntozier,

    I have not been able to make it go.  When opening the browser to finish the installation process i get the ubuntu apache2 site default site. See attached file.

    I have been modifying  the osticket.conf file but no results yet.

    Below the configuration file:

    <VirtualHost *:80>
            # The ServerName directive sets the request scheme, hostname and port that
            # the server uses to identify itself. This is used when creating
            # redirection URLs. In the context of virtual hosts, the ServerName
            # specifies what hostname must appear in the request's Host: header to
            # match this virtual host. For the default virtual host (this file) this
            # value is not decisive as it is used as a last resort host regardless.
            # However, you must set it for any further virtual host explicitly.

            DocumentRoot /var/www/html/osticket/upload/

            <Directory /var/www/html/osticket/upload/>
            Options Indexes FollowSymLinks MultiViews
            AllowOverride All

            # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
            # error, crit, alert, emerg.
            # It is also possible to configure the loglevel for particular
            # modules, e.g.
            #LogLevel info ssl:warn

            ErrorLog /var/log/apache2/
            CustomLog /var/log/apache2/ common

            #ErrorLog ${APACHE_LOG_DIR}/error-osticket.log
            #CustomLog ${APACHE_LOG_DIR}/access-osticket.log combined

            # For most configuration files from conf-available/, which are
            # enabled or disabled at a global level, it is possible to
            # include a line for only one particular virtual host. For example the
            # following line enables the CGI configuration for this host only
            # after it has been globally disabled with "a2disconf".
            #Include conf-available/serve-cgi-bin.conf

    Hope you can guide me out.


  • I dont know ubuntu.

    In Debian after you create a config file you have a2ensite configfile.ext
    Then you have to restart Apache.
    Have you done that?
  • Hi ntozier,

    Yes, i created a copy of sample file

    sudo cp /etc/apache2/sites-available/000-default.conf /etc/apache2/sites-available/osticket.conf

    sudo nano /etc/apache2/sites-available/osticket.conf

    ln -s /etc/apache2/sites-available/osticket.conf /etc/apache2/sites-enabled/osticket.conf

    Modified the file with my data
    <VirtualHost my-domain.tld:80>

    ServerName my-domain.tld
    ServerAdmin webmaster@localhost
    DocumentRoot /var/www/html/osticket/upload/

    <Directory /var/www/html/osticket/upload/>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride All

    ErrorLog ${APACHE_LOG_DIR}/error-osticket.log
    CustomLog ${APACHE_LOG_DIR}/access-osticket.log combined

    sudo a2ensite osticket.conf
    sudo service apache2 restart

    Still no success.

    Any other suggestions?

  • Hi Ntozier,

    I´ve reinstalled all the system again and now it is working with no white bar of death  yeahh!!

    However the links given to me are the following

    Your osTicket URL:http://domainname/osticket/upload/    
    Your Staff Control Panel:http://domainname/osticket/upload/scp

    Can this be modify to a shorter link access ? like

    Your osTicket URL:http://domainname/osticket
    Your Staff Control Panel:http://domainname/osticket/scp

    Hope you can help.

  • @enriqueman

    Yes, simply move all the contents from upload/ to osticket/. Once you do this update the Helpdesk URL in Admin Panel > Settings > System.

    I hope this helps! Cheers.
  • Hi Kevin,

    Thanks !! Let me try it.

Sign In or Register to comment.