Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Closed Ticket Alerts Support and Alert Dept Members MOD

2»

Comments

  • I wrote You a PM
  • I am just updating this thread to let anyone reading it know that I followed up with the last poster and found out that the code is working fine. I believe the real problem was that the email autoresponders were not turned on in the settings. So at this time I am confident that the close alert code MOD is fine and anyone wanting to install it should be confident that it will work.
  • Changes to be done to get the templates shown
    sandum150;38862 said:
    Also, when i open to edit the new created templates, it doesn't loading the contents (body and subject). But they are in the database...

    P.S. no email alerts on closed tickets
    Hi Sandum,

    Find the below code:
    case 'overdue_alert':
    $tpl=array('subj'=>$this->ht['ticket_overdue_subj'],'body'=>$this->ht['ticket_overdue_body']);
    break;


    after that add the below code:
    case 'closed_alert':
    $tpl=array('subj'=>$this->ht['ticket_closed_subj'],'body'=>$this->ht['ticket_closed_body']);
    break;
    case 'ticket_upd_mbers_alert':
    $tpl=array('subj'=>$this->ht['ticket_upd_mbers_subj'],'body'=>$this->ht['ticket_upd_mbers_body']);
    break;


    You will be able to edit the closed ticket and dept members template.
  • Hi

    Thanks very much for your work! This mod is really helpful for us.

    I have followed all of the instructions in your posts (twice actually as I had replaced all of the files and tried again).

    When I try to turn on close alerts in the Alerts and Notices area I get:

    "Unable to update settings - correct errors below and try again"

    But there are no errors below.

    Close emails do not work..

    Many thanks,

    Laurence

    Edit:
    "Sorry! The problem was caused by me.

    My MySQL database was missing message_alert_dept_manager from some earlier troubleshooting I had done.

    I used the settings from the setup file:
    `message_alert_dept_manager` tinyint(1) unsigned NOT NULL default '0'
    All ok now :).
    "
  • LaurenceGough;40632 said:



    Close emails do not work..

    Many of the settings need to be confirmed. Do you have your auto-responders turned on? If you have the ability to let me into your ticket system - send me a PM with a login and I will check it out for you.

    Thanks,

    Sturg
  • Thanks very much Sturg, message sent.

    Auto responders are all on.

    Cheers,

    Laurence
  • Laurence - some instructions left for you in PM. TTL!
  • Sorry! The problem was caused by me.

    My MySQL database was missing message_alert_dept_manager from some earlier troubleshooting I had done.

    I used the settings from the setup file:
    `message_alert_dept_manager` tinyint(1) unsigned NOT NULL default '0'
    All ok now :).

    I am sorry to have wasted your time. I will edit my first post.

    Great mod! :)
  • Part 2:

    Then go to include\class.template.php


    find the following code

    case 'overdue_alert':
    $sql.=',ticket_overdue_subj='.db_input($vars['subj']).',ticket_overdue_body='.db_input($vars['body']);
    break;


    And after it add the following:

    //sturg2013
    case 'closed_alert':
    $sql.=',ticket_closed_subj='.db_input($vars['subj']).',ticket_closed_body='.db_input($vars['body']);
    break;
    case 'ticket_upd_mbers_alert':
    $sql.=',ticket_upd_mbers_subj='.db_input($vars['subj']).',ticket_upd_mbers_body='.db_input($vars['body']);
    break;

    I'm new in programing and I'm trying to apply this MOD in version 1.9
    And only I could get to the part 2. The problem is trying to modify the file include / class.template.php
    In version 1.9 no longer uses 'case'
    And I do not know how to continue.
    I will thank your help

    P.D. I'm not very good speaking english
  • This thread is posted in the 1.7 section of the forums for version 1.7.
    It does not work and was not written for 1.9.
  • all right
    I will try in the indicated section
    Thank You
Sign In or Register to comment.