Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

can't access admin panel

After "successful" installation and exposing error display, I see the following:

Fatal error: Cannot redeclare class Config in
myserver\upload\include\clas s.config.php on line 18

Any ideas how to fix this one? :confused:

Comments

  • I believe your issues are the same as elkriefy's, sounds like a php configuration issue on your host.
  • My error is different than elkriefy's, but if it is a php configuration problem, any idea how I can fix it?

    I am running
    xampp 1.6.5
    mysql 5.0.51
    php 5.2.5

    I have been trying to get this system to work for weeks and am about ready to give up!
  • first, upload the files for the upgrade to rc2. you just need to upload them to replace the existing files. then see if you still have the issue. If you do you will need to create a php.ini file to turn off register globals.
  • Thanks. I completed the upgrade and checked the php.ini file I already had, which shows 'register_globals = Off' already. Anywhere else I should check?
  • jessica;407 said:
    Thanks. I completed the upgrade and checked the php.ini file I already had, which shows 'register_globals = Off' already. Anywhere else I should check?
    PM for help. Curious to find out the source of the error.
  • Hi Peter,

    I have the same error. First I only see a white site, after changing logging parameters this warning appears:

    Fatal error: Cannot redeclare class config in E:\xampp\htdocs\ticket\include\class.config.php on line 18
    Is there a solution force this problem?
    My system:

    XAMMP on Windows from apachefriends.org
    php5
    mysql5

    I´m using RC2.
  • don;538 said:
    Hi Peter,

    I have the same error. First I only see a white site, after changing logging parameters this warning appears:

    Is there a solution force this problem?
    My system:

    XAMMP on Windows from apachefriends.org
    php5
    mysql5

    I´m using RC2.

    I have the same system and have the same problem.

    Please write down the Solution...

    Thank you for help!
  • can you look at the config table within the sql database to be sure it has been populated with the default record?
  • For people who are still having troubles installing and running osTicket on a localhost. See http://www.osticket.com/forums/showthread.php?t=184 for more info.
Sign In or Register to comment.